Project

Profile

Help

Issue #346

Error message when trying to upgrade with puppet update when the latest is installed is misleading

Added by pthomas@redhat.com almost 7 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.1 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

Error message indicates that the module is not installed, when trying to update puppet module and you have the latest installed

[root@cloud-qe-8 ~]# pulp-admin puppet consumer install run --consumer-id el5-consumer -u puppetlabs/stdlib/
This command may be exited via ctrl+c without affecting the request.

[\]
1 change was made

Install Succeeded

[root@cloud-qe-8 ~]# pulp-admin puppet consumer update run --consumer-id el5-consumer -u puppetlabs/stdlib/
Update task created with id [ a17fef59-1c1b-4e24-95f2-d24ff927a4c3 ]

This command may be exited via ctrl+c without affecting the request.

[\]
Could not upgrade 'puppetlabs-stdlib'; module is not installed

Operation executed, but no changes were made.

[root@mgmt3 ~]# puppet module list
/etc/puppet/modules
└── puppetlabs-stdlib (v3.2.0)
/usr/share/puppet/modules (no modules installed)
[root@mgmt3 ~]#

Version-Release number of selected component (if applicable):
[root@cloud-qe-8 ~]# rpm -q pulp-server
pulp-server-2.1.0-0.26.beta.noarch
[root@cloud-qe-8 ~]#

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #927466 +

History

#1 Updated by mhrivnak almost 7 years ago

Looks like this is an error in the puppet tool from upstream. I have filed a bug with them:

http://projects.puppetlabs.com/issues/19906

$ puppet module upgrade puppetlabs-stdlib --render-as json
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
notice: Preparing to upgrade 'puppetlabs-stdlib' ...
notice: Found 'puppetlabs-stdlib' (v3.2.0) in /home/mhrivnak/.puppet/modules ...
notice: Downloading from http://forge.puppetlabs.com ...
{"module_name":"puppetlabs-stdlib","installed_version":"v3.2.0","requested_version":"latest","result":"noop","error":{"oneline":"Could not upgrade 'puppetlabs-stdlib'; module is not installed","multiline":"Could not upgrade module 'puppetlabs-stdlib' (v3.2.0 -> latest: v3.2.0)\n The installed version is already the latest version\n Use `puppet module install --force` to re-install this module"}}

Didn't enjoy reading that? Let me pretty-print the json for you...

{
"error": {
"multiline": "Could not upgrade module puppetlabs-stdlib (v3.2.0 -> latest: v3.2.0)\n The installed version is already the latest version\n Use `puppet module install --force` to re-install this module",
"oneline": "Could not upgrade puppetlabs-stdlib; module is not installed"
},
"installed_version": "v3.2.0",
"module_name": "puppetlabs-stdlib",
"requested_version": "latest",
"result": "noop"
}

Note the difference between the "multiline" vs. "oneline" error messages.

+ This comment was cloned from Bugzilla #927466 comment 1 +

#2 Updated by jason.dobies@redhat.com almost 7 years ago

Not entirely sure how to handle this. I'll align it to 2.2 so we check on it again next month, otherwise I'll just keep sliding it out so we keep an eye on their bug.

+ This comment was cloned from Bugzilla #927466 comment 2 +

#3 Updated by mhrivnak almost 7 years ago

Looks like this should be fixed in puppet 3.3, and as such is blocked by #1014001

+ This comment was cloned from Bugzilla #927466 comment 3 +

#4 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX
  • Severity set to 2. Medium

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF