Project

Profile

Help

Issue #2411

Missing support for ZIP files

Added by jiri.tyr@gmail.com almost 4 years ago. Updated about 1 month ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Python:
1.1.1
Platform Release:
Target Release - Python:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

I'm currently using the latest pulp-python-plugins-1.1.3 and I'm not able to sync PYPI packages in ZIP format:

# Create repo with two packages
pulp-admin python repo create --repo-id my_pypi --feed https://pypi.python.org/ --package-names importlib,wsgiref
pulp-admin python repo sync run --repo-id my_pypi

# This finds importlib package in the version 1.4.0 but it's a ZIP file!
curl -s https://pypi.python.org/simple/importlib/ | grep 1.0.4

# This finds no importlib package - only tar.gz files are available
curl -s https://localhost/pulp/python/simple/importlib/ | grep 1.0.4

# This finds the wsgiref package
curl -s https://pypi.python.org/simple/ | grep wsgiref

# This finds no wsgiref package because the remote package contains only ZIP files
curl -s https://localhost/pulp/python/simple | grep wsgiref

Related issues

Is duplicate of Python Support - Story #1883: As a user, I can sync and publish all package typesCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com almost 4 years ago

  • Is duplicate of Story #1883: As a user, I can sync and publish all package types added

#2 Updated by amacdona@redhat.com almost 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF