Project

Profile

Help

Issue #2235

Download progress won't stream to clients

Added by behi_1370 over 3 years ago. Updated 9 months ago.

Status:
CLOSED - DUPLICATE
Priority:
High
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
3. High
Version - Nectar:
master
Platform Release:
Blocks Release:
Target Release - Nectar:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

I cloned nectar master branch repository, install and replace it with nectar 1.5.2-1 and test download files from clients.
The problem that keeps proxy is solved but now another problem occurred. Packages won’t stream while downloading is in progress. For example when I want to download some packages, every packages completely download in server first and after that it serve packages to client so I can’t see the progress bar of downloading packages and also if I want to download a large file, it will response a timeout error on proxyset


Related issues

Duplicated by Nectar - Issue #2696: Pulp streamer not 'streaming' content to squid CLOSED - CURRENTRELEASE Actions

History

#1 Updated by amacdona@redhat.com over 3 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#2 Updated by alexjfisher almost 3 years ago

  • Duplicated by Issue #2696: Pulp streamer not 'streaming' content to squid added

#3 Updated by alexjfisher over 2 years ago

I'm almost certain this is a duplicate of https://pulp.plan.io/issues/2696 (which is now fixed).

There's one slight confusion though. Is behi_1370 using 1.5.2-1 or master from 2016/09/09
1.5.2 doesn't include the regression fixed in 2696, but master in september 2016 would have.

The issue description otherwise matches perfectly.

#4 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Since this does seem like a duplicate, I'm going to close it as such. Once the fix for Issue 2696 is into a build, if the reporter (or anyone) can reproduce this issue, please post a comment and we can reopen.

#5 Updated by bmbouter 9 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF