Project

Profile

Help

Story #1975

As a user, I can sync V2 content from an integrated OpenShift registry

Added by twaugh over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Target Release - Docker:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

In order to sync V2 content from the integrated registry provided with OpenShift, pulp_docker needs to handle Basic auth.

The OpenShift registry does not currently allow unauthenticated pull access, and requires Basic auth with a password that is the access token for the given username. OpenShift service accounts can also authenticate this way, using the username "serviceaccount" and using their service account access token as the password.

There is related work aiming to allow unauthenticated pulls from the OpenShift registry in some configurations:
https://bugzilla.redhat.com/show_bug.cgi?id=1331191


Related issues

Is duplicate of Docker Support - Story #1291: As a user, I can sync feeds that require username/password authenticationCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 4 years ago

  • Sprint Candidate changed from No to Yes

#2 Updated by mhrivnak over 4 years ago

There's a good chance this already works, even though the options aren't documented on this importer. You could try setting "basic_auth_username" and "basic_auth_password" in the importer config.

If it doesn't work, it should be easy for us to get working. It could be something as simple as making the importer's config validator allow these settings.

#3 Updated by mhrivnak over 4 years ago

  • Is duplicate of Story #1291: As a user, I can sync feeds that require username/password authentication added

#4 Updated by mhrivnak over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Sprint Candidate changed from Yes to No

#5 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF