Project

Profile

Help

Issue #1953

Migration failing on upgrade from 2.8.3->2.8.4

Added by pthomas@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
Urgent
Assignee:
Start date:
Due date:
Estimated time:
Severity:
3. High
Version - Docker:
Platform Release:
Target Release - Docker:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Database migration is failing for upgrade from 2.8.3 to 2.8.4


[root@yttrium ~]# rpm -qa |grep pulp
python-kombu-3.0.33-5.pulp.el7.noarch
python-pulp-rpm-common-2.8.4-0.1.beta.el7.noarch
pulp-server-2.8.4-0.1.beta.el7.noarch
pulp-admin-client-2.8.4-0.1.beta.el7.noarch
python-pulp-docker-common-2.0.2-0.1.beta.el7.noarch
python-pulp-bindings-2.8.4-0.1.beta.el7.noarch
pulp-puppet-plugins-2.8.4-0.1.beta.el7.noarch
pulp-puppet-admin-extensions-2.8.4-0.1.beta.el7.noarch
python-pulp-client-lib-2.8.4-0.1.beta.el7.noarch
python-pulp-oid_validation-2.8.4-0.1.beta.el7.noarch
pulp-rpm-plugins-2.8.4-0.1.beta.el7.noarch
pulp-rpm-admin-extensions-2.8.4-0.1.beta.el7.noarch
pulp-docker-plugins-2.0.2-0.1.beta.el7.noarch
pulp-docker-admin-extensions-2.0.2-0.1.beta.el7.noarch
python-pulp-common-2.8.4-0.1.beta.el7.noarch
python-pulp-repoauth-2.8.4-0.1.beta.el7.noarch
pulp-selinux-2.8.4-0.1.beta.el7.noarch
python-isodate-0.5.0-4.pulp.el7.noarch
python-pulp-puppet-common-2.8.4-0.1.beta.el7.noarch
[root@yttrium ~]# 

1. Install pulp 2.8.3
2. Populate with content 
3. Make sure include rpm, iso, puppet, docker contents
4. Yum update to 2.8.4 beta
5. Run pulp-manage-db

[root@yttrium ~]# sudo -u apache pulp-manage-db
Attempting to connect to localhost:27017
Attempting to connect to localhost:27017
Write concern for Mongo connection: {}
Loading content types.
Loading type descriptors []
Parsing type descriptors
Validating type descriptor syntactic integrity
Validating type descriptor semantic integrity
Loading unit model: puppet_module = pulp_puppet.plugins.db.models:Module
Loading unit model: erratum = pulp_rpm.plugins.db.models:Errata
Loading unit model: distribution = pulp_rpm.plugins.db.models:Distribution
Loading unit model: package_group = pulp_rpm.plugins.db.models:PackageGroup
Loading unit model: package_category = pulp_rpm.plugins.db.models:PackageCategory
Loading unit model: iso = pulp_rpm.plugins.db.models:ISO
Loading unit model: package_environment = pulp_rpm.plugins.db.models:PackageEnvironment
Loading unit model: drpm = pulp_rpm.plugins.db.models:DRPM
Loading unit model: srpm = pulp_rpm.plugins.db.models:SRPM
Loading unit model: rpm = pulp_rpm.plugins.db.models:RPM
Loading unit model: yum_repo_metadata_file = pulp_rpm.plugins.db.models:YumMetadataFile
Loading unit model: docker_blob = pulp_docker.plugins.models:Blob
Loading unit model: docker_manifest = pulp_docker.plugins.models:Manifest
Loading unit model: docker_image = pulp_docker.plugins.models:Image
Loading unit model: docker_tag = pulp_docker.plugins.models:Tag
Updating the database with types []
Found the following type definitions that were not present in the update collection [puppet_module, docker_tag, docker_manifest, docker_blob, erratum, yum_repo_metadata_file, package_group, package_category, iso, package_environment, drpm, srpm, rpm, distribution, docker_image]
Updating the database with types [puppet_module, docker_tag, erratum, docker_blob, docker_manifest, yum_repo_metadata_file, package_group, package_category, iso, package_environment, drpm, distribution, rpm, srpm, docker_image]
Content types loaded.
Ensuring the admin role and user are in place.
Admin role and user are in place.
Beginning database migrations.
Migration package pulp.server.db.migrations is up to date at version 23
The database for migration package pulp_docker.plugins.migrations is at version 2, which is larger than the latest version available, 1.
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 193, in main
    return _auto_manage_db(options)
  File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 256, in _auto_manage_db
    migrate_database(options)
  File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 73, in migrate_database
    raise DataError(msg)
DataError: The database for migration package pulp_docker.plugins.migrations is at version 2, which is larger than the latest version available, 1.

[root@yttrium ~]# 

From the log

May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:INFO: Migration package pulp.server.db.migrations is up to date at version 23
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: The database for migration package pulp_docker.plugins.migrations is at version 2, which is larger than the latest version available, 1.
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224) Traceback (most recent call last):
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224)   File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 193, in main
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224)     return _auto_manage_db(options)
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224)   File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 256, in _auto_manage_db
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224)     migrate_database(options)
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224)   File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 73, in migrate_database
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224)     raise DataError(msg)
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224) DataError: The database for migration package pulp_docker.plugins.migrations is at version 2, which is larger than the latest version available, 1.
May 27 13:29:09 yttrium.idmqe.lab.eng.bos.redhat.com pulp[23300]: pulp.server.db.manage:CRITICAL: (23300-12224)

History

#1 Updated by semyers over 4 years ago

  • Project changed from RPM Support to Docker Support

#3 Updated by semyers over 4 years ago

I have an error in the 2.8.4 release config that caused this. I'll fix the error now and build beta 2 on Tuesday.

#4 Updated by semyers over 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to semyers
  • Priority changed from High to Urgent
  • Platform Release set to 2.8.4

#5 Updated by semyers over 4 years ago

  • Status changed from ASSIGNED to CLOSED - NOTABUG

This was a release engineering (me) fail. I've corrected the release config, and 2.8.4 is now going to be a preempted hotfix release, so I'll make sure to do it right for 2.8.5. :)

#6 Updated by mhrivnak over 4 years ago

  • Platform Release deleted (2.8.4)

#7 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF