Project

Profile

Help

Issue #1587

Synchronizing with a feed that uses a slash in "upstream name" causes TypeError: 'StringField' object is not callable

Added by rbarlow over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - NOTABUG
Priority:
High
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version - Docker:
master
Platform Release:
Target Release - Docker:
2.0.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Synchronizing with feeds that have a slash in the upstream name causes this traceback:

celery.worker.job:ERROR: (18735-54240) Task pulp.server.managers.repo.sync.sync[05f1ed6e-9573-4b7c-950a-da19154d89f5] raised unexpected: TypeError("'StringField' object is not callable",)
celery.worker.job:ERROR: (18735-54240) Traceback (most recent call last):
celery.worker.job:ERROR: (18735-54240)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
celery.worker.job:ERROR: (18735-54240)     R = retval = fun(*args, **kwargs)
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/server/async/tasks.py", line 473, in __call__
celery.worker.job:ERROR: (18735-54240)     return super(Task, self).__call__(*args, **kwargs)
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/server/async/tasks.py", line 103, in __call__
celery.worker.job:ERROR: (18735-54240)     return super(PulpTask, self).__call__(*args, **kwargs)
celery.worker.job:ERROR: (18735-54240)   File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 437, in __protected_call__
celery.worker.job:ERROR: (18735-54240)     return self.run(*args, **kwargs)
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/server/controllers/repository.py", line 755, in sync
celery.worker.job:ERROR: (18735-54240)     sync_report = sync_repo(transfer_repo, conduit, call_config)
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/server/async/tasks.py", line 658, in wrap_f
celery.worker.job:ERROR: (18735-54240)     return f(*args, **kwargs)
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp_docker/plugins/pulp_docker/plugins/importers/importer.py", line 85, in sync_repo
celery.worker.job:ERROR: (18735-54240)     return self.sync_step.process_lifecycle()
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/plugins/util/publish_step.py", line 562, in process_lifecycle
celery.worker.job:ERROR: (18735-54240)     super(PluginStep, self).process_lifecycle()
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/plugins/util/publish_step.py", line 159, in process_lifecycle
celery.worker.job:ERROR: (18735-54240)     step.process()
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/plugins/util/publish_step.py", line 249, in process
celery.worker.job:ERROR: (18735-54240)     self._process_block()
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp/server/pulp/plugins/util/publish_step.py", line 293, in _process_block
celery.worker.job:ERROR: (18735-54240)     self.process_main()
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp_docker/plugins/pulp_docker/plugins/importers/sync.py", line 225, in process_main
celery.worker.job:ERROR: (18735-54240)     digest, manifest = self.parent.index_repository.get_manifest(tag)
celery.worker.job:ERROR: (18735-54240)   File "/home/fedora/devel/pulp_docker/plugins/pulp_docker/plugins/registry.py", line 366, in get_manifest
celery.worker.job:ERROR: (18735-54240)     digest = models.Manifest.digest(manifest)
celery.worker.job:ERROR: (18735-54240) TypeError: 'StringField' object is not callable

History

#1 Updated by rbarlow over 5 years ago

  • Status changed from NEW to CLOSED - NOTABUG

I believe this issue may have been environmental, as I am not able to reproduce it with a clean installation.

#2 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF