Project

Profile

Help

Story #1573

As a user, I can use basic auth to retrieve content from docker hub

Added by amacdona@redhat.com almost 5 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Target Release - Docker:
Groomed:
No
Sprint Candidate:
Yes
Tags:
Pulp 2
Sprint:
Quarter:

Description

In the registry/v2 API, requests may be required to have a bearer token. It may be required to pass basic auth parameters to the endpoint that generates this token. Pulp's docker plugin should support passing these arguments.


Related issues

Is duplicate of Docker Support - Story #1291: As a user, I can sync feeds that require username/password authenticationCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com almost 5 years ago

  • Project changed from Pulp to Docker Support

#2 Updated by amacdona@redhat.com almost 5 years ago

  • Sprint Candidate changed from No to Yes

#3 Updated by rbarlow almost 5 years ago

Austin,

Is this story any different than #1291? It sounds like a duplicate to me, so I'm going to close it as such. If you disagree, feel free to reopen!

#4 Updated by rbarlow almost 5 years ago

  • Is duplicate of Story #1291: As a user, I can sync feeds that require username/password authentication added

#5 Updated by rbarlow almost 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#6 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF