Project

Profile

Help

Refactor #1080

Pulp - Refactor #765: Convert Pulp to use MongoEngine

Convert the DockerManifest model to use mongoengine model

Added by rbarlow almost 6 years ago. Updated about 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Target Release - Docker:
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Pulp 2
Sprint:
Quarter:

Description

As per https://pulp.plan.io/issues/967, a new DockerManifest model has been created. However, as it was created against the 2.6 branches, it has not been converted to the new-style model type yet. This task is to earmark the conversion work.

Deliverables:

  • A "new-style" model for the DockerManifest model, part of the Docker v2 API.
  • Follow the conversion guide

The Docker data type is documented here: https://github.com/docker/distribution/blob/release/2.0/docs/spec/manifest-v2-1.md


Related issues

Is duplicate of Docker Support - Refactor #863: Convert pulp_docker to use MongoEngine models for unitsCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by rbarlow almost 6 years ago

  • Blocked by Task #967: Create a "manifest" model added

#2 Updated by rbarlow almost 6 years ago

  • Blocked by Refactor #863: Convert pulp_docker to use MongoEngine models for units added

#3 Updated by mhrivnak almost 6 years ago

  • Tracker changed from Task to Refactor
  • Groomed changed from No to Yes

#4 Updated by bmbouter almost 6 years ago

  • Description updated (diff)

#5 Updated by bmbouter almost 6 years ago

  • Blocked by deleted (Refactor #863: Convert pulp_docker to use MongoEngine models for units)

#6 Updated by bmbouter almost 6 years ago

  • Subject changed from Convert the DockerManifest model to the new-style model to Convert the DockerManifest model to use mongoengine model
  • Parent task set to #765

#7 Updated by rbarlow over 5 years ago

  • Status changed from NEW to ASSIGNED

#8 Updated by rbarlow over 5 years ago

  • Blocked by deleted (Task #967: Create a "manifest" model)

#9 Updated by rbarlow over 5 years ago

  • Status changed from ASSIGNED to CLOSED - DUPLICATE

#10 Updated by rbarlow over 5 years ago

  • Is duplicate of Refactor #863: Convert pulp_docker to use MongoEngine models for units added

#11 Updated by bmbouter about 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF