Pulp 2 13 2 Test Result Summary

Summary

Started On: June 13, 2017
Finished On: June 20, 2017
Version: 2.13.2
Result : Success
Build URL: N/A
Summary

This release included bug fixes. The QE tasks in the release process included identifying issues that needed to be added to automation backlog, creating github issues, making sure automation jobs pass and upgrade automation jobs passing. Upgrade automation failed to run the pulp-smash on the upgraded pulp.

Pulp QE approve the release of pulp 2.13.2

Beta History
Beta1 : June 13, 2017

Issues Addressed
================

Pulp
       2776    pulp-manage-db requires pulp services to be shut down even in dry run mode
       2770    Tasks stuck in waiting state if received while qpidd is down
       2741    Pulp is not compatible with Django 1.10
       2728    Check and fix Pulp compatibility with python-mongoengine >= 0.11.0 in Fedora 26/Rawhide
       2639    Upgrade fails on Fedora

Puppet Support
2750 pulp_puppet is not compatible with django 1.10
1237 Puppet Install Distributor does not raise exception when non-optional install_path is missing

RPM Support
2797 Single consumer aplicability generation does not work unless profile already has applicability generated

View this list in Redmine:
http://bit.ly/2sxXeIz

Fedora Uprade
=============
This release resolves the issue (#2639) of upgrading from the pulp packages in Fedora's repositories to the upstream pulp packages.

Pulp-Smash issues

https://github.com/PulpQE/pulp-smash/milestone/20

Open

https://github.com/PulpQE/pulp-smash/issues/686
https://github.com/PulpQE/pulp-smash/issues/650

Closed

https://github.com/PulpQE/pulp-smash/issues/679
https://github.com/PulpQE/pulp-smash/issues/676