Project

Profile

Help

« Previous | Next » 

Revision 0db2dcbb

Added by bmbouter 10 months ago

Adds PulpPluginAppConfig.version warnings

Starting with 3.10 plugins will be required to declare their version as the version attribute on the PulpPluginAppConfig subclass. This adds warnings starting in 3.9 encouraging plugin writers to do so.

Additionally, it sets the version on PulpAppConfig so that it doesn't complain about itself. The bumpversion spec also will bump this string at release time.

closes #6671