Project

Profile

Help

Task #5151

Updated by dalley 6 months ago

These two patches need to be applied:
https://github.com/openSUSE/libsolv/commit/e33bb18fc9205d79228503e13f7a2b6502dd7675
https://github.com/openSUSE/libsolv/pull/339

edit: Possibly another one will be needed -- ping me before completing this build.

Additionally, the current version "0.7.2" has a couple of memory leaks and null pointer dereferences. I've not directly experienced a problem with them, but CVEs are filed, so it's probably best to upgrade.

Any version >= 0.7.4 will allow the two existing patches to be dropped.

"0.7.5-1" is what is currently in Fedora. I have looked through the changelog and have not seen any API breaking changes.

Back