Project

Profile

Help

Verification Required

Apply Clear

# Project Tracker Status Priority Severity Subject Author Assignee
  (blank) 5574 Collapse all/Expand all
3595 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Remove sync_mode and download_policy from docs daviddavis bmbouter Actions
3598 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium During sync, tar.gz files are being saved as .tar files daviddavis Actions
3610 Ansible Plugin Issue NEW Normal 2. Medium 500 when publishing a repository without any versions daviddavis Actions
3792 Ansible Plugin Issue NEW Normal 2. Medium Ansible content units are missing fields in the API from ModelSerializer like 'id' and 'created' daviddavis Actions
3818 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium The AnsibleRole as a content unit is problematic daviddavis daviddavis Actions
3898 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Filters inherit from a Django's FilterSet not from our class vdusek vdusek Actions
4155 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium TravisCI fails - ModuleNotFoundError: No module named 'pulpcore.plugin.changeset' daviddavis mdellweg Actions
4576 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Client Instructions to Fetch from pulp_ansible are broken bmbouter daviddavis Actions
4820 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Update pulp_ansible to use RepositoryVersionDistribution daviddavis Actions
4910 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium AnsibleDistribution allows setting repo and repo_version together in a PUT request rochacbruno fao89 Actions
4920 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection - Repository versions not being update after successive syncs kersom bmbouter Actions
4939 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Docs - Collections upload workflows is using role endpoints kersom bmbouter Actions
4970 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection - RepositoryDistribution does not provide url to consume to cosume content from Pulp kersom fao89 Actions
4996 Ansible Plugin Issue CLOSED - CURRENTRELEASE Low 2. Medium Ansible collection remote doesn't handle trailing / in sync url sajha fao89 Actions
4997 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 2. Medium Pulp3 Ansible Collection remote doesn't seem to be able to sync more than 1 repo sajha bmbouter Actions
4999 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection - Sync produces error messages in log system kersom bmbouter Actions
5001 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 2. Medium Provide content_ansible_collection_read method for ansible collections sajha bmbouter Actions
5155 Ansible Plugin Issue CLOSED - WORKSFORME Normal 2. Medium Ansible Collection Is Installed With Wrong Version ompragash bmbouter Actions
5167 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection Remote sync does not accept mirror parameter sajha fao89 Actions
5209 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Uploading same collection twice causes 500 error bmbouter fao89 Actions
5281 Ansible Plugin Issue NEW Normal 2. Medium Ansible collection upload URL missing /pulp/api/v3/ kersom Actions
5301 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Add endpoints for CollectionImports osapryki osapryki Actions
5309 Ansible Plugin Issue NEW Normal 2. Medium Download only specified version on requirements.yml fao89 Actions
5310 Ansible Plugin Issue NEW Normal 2. Medium Full text search trigger is not executed on insert osapryki Actions
5323 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium syncing all collections results in 'too many open files' jsherril@redhat.com Actions
5332 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Provide content_ansible_collection_read method for ansible collections jsherril@redhat.com fao89 Actions
5346 Ansible Plugin Issue NEW Normal 2. Medium Wrong url resolution when path is the last component of prefix osapryki Actions
5357 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Galaxy API v3 collection upload should return valid imports URL osapryki osapryki Actions
5358 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Galaxy API v3 collection upload should create CollectionImport object osapryki osapryki Actions
5365 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection version API should include "id" field osapryki Actions
5459 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Response data from CollectionVersionViewSet is incompatible with ansible-galaxy alikins alikins Actions
5466 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium No defaults provided for ansible_api_hostname and ansible_content_hostname bmbouter bmbouter Actions
5494 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium pulp assuming a pagesize of 10 when syncing from the ansible galaxy api jsherril@redhat.com fao89 Actions
5521 Ansible Plugin Issue NEW Normal 2. Medium Collection model that has no CollectionVersion related objects needs to be removed somehow when orphaned bmbouter Actions
5555 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 2. Medium Error when uploading a collection to v3 daviddavis bmbouter Actions
5569 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Cannot poll a collection import immediately after the collection is uploaded daviddavis Actions
5572 Ansible Plugin Issue CLOSED - CURRENTRELEASE Urgent 2. Medium pulp_ansible/app/tasks/collections.py:import_collections() throws FieldError alikins daviddavis Actions
5577 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium As a user, I can update a collection to deprecate it daviddavis fao89 Actions
5583 Ansible Plugin Issue CLOSED - DUPLICATE Normal 2. Medium Add methods/mixins to galaxy.v3.views.CollectionViewSet to allow changing is_deprecated field alikins Actions
5586 Ansible Plugin Issue NEW Normal 2. Medium error with pulp-ansible: KeyError: 'path' jsherril@redhat.com Actions
5621 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Add sort parameters to Collection Version List newswangerd daviddavis Actions
5644 Ansible Plugin Issue CLOSED - NOTABUG Normal 2. Medium consume content test is executed on the pulp server dkliban@redhat.com Actions
5645 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Need to return deprecated status in collection versions endpoint newswangerd daviddavis Actions
5647 Ansible Plugin Issue NEW Normal 2. Medium Pulp Ansible Galaxy V3 Collection Artifact download_url field can give unresolveable URLs ironfroggy Actions
5666 Ansible Plugin Issue NEW Normal 2. Medium Failed imports leave orphaned artifacts blocking subsequent attempts ironfroggy Actions
5670 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Add certiication param to collection version endpoint newswangerd Actions
5674 Ansible Plugin Issue NEW Normal 2. Medium All import tasks are assigned to the same worker osapryki Actions
5711 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Unnecessary DELETE action for set_certified method romanblanco Actions
5745 Ansible Plugin Issue NEW Normal 2. Medium Sync throws error: "filename 'MANIFEST.json' not found" daviddavis Actions
5748 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium /pulp/api/v3/ raises 500 error daviddavis Actions
5783 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 2. Medium Ansible repositories API doesn't have a /modify/ endpoint iballou bmbouter Actions
5905 Ansible Plugin Issue NEW Normal 2. Medium ansible-galaxy collection publish fails bmbouter Actions
6116 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection sync task fails syncing from automation-hub because of 'versions_url' changes alikins Actions
6129 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium sync doesn't do anything because 'download_url' moved between galaxy v2/v3 API change alikins Actions
6223 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Pulp configured with S3 doesn't include file type extension in Content-Disposition header chouseknecht fao89 Actions
6239 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium pulp_ansible returns 404 for import status URL with trailing slash jborean bmbouter Actions
6248 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium webserver_snippts are missing from pulp_ansible 0.2.0b9 which is supposed to have them bmbouter bmbouter Actions
6317 Ansible Plugin Issue NEW Normal 2. Medium Enable v3 api for distributions daviddavis Actions
6510 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium v3.serializers.CollectionVersionSerializer needs to include distro base_path in 'download_url' alikins fao89 Actions
6657 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Better error messages if collection field doesn't fit DB field length osapryki fao89 Actions
6855 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Automation hub tarballs have invalid name formatting. osapryki osapryki Actions
6860 Ansible Plugin Issue CLOSED - DUPLICATE Normal 2. Medium Replace URLField with CharField fao89 Actions
6889 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Missing requirements.txt fao89 Actions
7032 Ansible Plugin Issue NEW Normal 2. Medium Provide a way for subclasses of pulp viewset that use serializers with href methods to override urls that are reversed alikins Actions
7305 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Rename ansible type newswangerd Actions
7353 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium bindings for ansible collection are too strict on documentation field jsherril@redhat.com fao89 Actions
7368 Ansible Plugin Issue MODIFIED Normal 2. Medium ANSIBLE_CONTENT_HOSTNAME should default to pulp_installer CONTENT_ORIGIN cmeyers fao89 Actions
7396 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection sync doesn't pull all collections from hub newswangerd fao89 Actions
7412 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection Remote sync breaks when requirements.yml is added. newswangerd fao89 Actions
7428 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium pulp_ansible collection list only shows collection if highest version in repo awcrosby fao89 Actions
7434 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium The requirements file on remote is limited to 255 chars daviddavis daviddavis Actions
7435 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Galaxy V3 API pagination does not match with pulp V3 API fao89 fao89 Actions
7504 Ansible Plugin Issue POST Normal 2. Medium Set deprecated status on synced collections. newswangerd fao89 Actions
7512 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Seeing some collections skipped with CollectionRemote with requirements.yml (related to https://github.com/ansible/galaxy_ng/issues/437) alikins fao89 Actions
7551 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Standalone galaxy_ng syncing from cloud.ci doesn't get docs for collections (https://github.com/ansible/galaxy_ng/issues/441) alikins Actions
7564 Ansible Plugin Issue NEW Normal 2. Medium Excess number of suboptimal queries when querying collections list osapryki Actions
7572 Ansible Plugin Issue NEW Normal 2. Medium Make MANIFEST.json and DIGEST.json available in the CollectionVersion serializer in the V3 API fao89 Actions
7632 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium CollectionVersion.contents are not being synced fao89 Actions
7643 Ansible Plugin Issue POST Normal 2. Medium Token is renewed for every call fao89 fao89 Actions
7647 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium ansible-galaxy v2 collections/{namespace}/{name} not matching with actual jborean Actions
7651 Ansible Plugin Issue CLOSED - WORKSFORME Normal 2. Medium Pulp Error: Network is unreachable during RepositoriesAnsibleApi.sync jdjeffers Actions
7686 Ansible Plugin Issue ASSIGNED Normal 2. Medium requirements.yml is not compatible with ansible-galaxy fao89 daviddavis Actions
7711 Ansible Plugin Issue CLOSED - DUPLICATE Normal 2. Medium pulp_ansible could not determine API version for url with 'api/v2' appended jdjeffers Actions
7734 Ansible Plugin Issue NEW Normal 2. Medium Validate the requirements.yml file daviddavis Actions
7739 Ansible Plugin Issue NEW Normal 2. Medium Requirement.yml code doesn't filter by version daviddavis Actions
7740 Ansible Plugin Issue NEW Normal 2. Medium Syncing requirements is not handling pagination correctly daviddavis Actions
7741 Ansible Plugin Issue NEW Normal 2. Medium Code doesn't handle requirements.yml sources with different api versions daviddavis Actions
7742 Ansible Plugin Issue POST Normal 2. Medium Setting a remote on a repo and syncing is broken daviddavis daviddavis Actions
3946 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 3. High Syncing from Galaxy is not working daviddavis Actions
4047 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 3. High pulp_ansible RC1 is missing code bmbouter bmbouter Actions
5226 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 3. High Migration 0004_add_fulltext_search_indexes fails when trying to udpate search verctor osapryki osapryki Actions
5299 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 3. High Bindings for pulp \ pulp ansible return python `repr()` for json fields osapryki fao89 Actions
5579 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 3. High Add the ability to set a certification status for a collection version newswangerd fao89 Actions
7669 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 3. High pulp_ansible galaxy collection endpoint, wrong data on empty repo awcrosby Actions
5571 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 4. Urgent Add the ability to filter collection versions by tag newswangerd daviddavis Actions
4891 CertGuard Issue CLOSED - CURRENTRELEASE Normal 1. Low The client side ssl cert for pulp should follow http header standards Anonymous bmbouter Actions
4900 CertGuard Issue CLOSED - CURRENTRELEASE Normal 2. Medium As a user I would like to know how to make pulp work with yum Anonymous Actions
6105 CertGuard Issue CLOSED - CURRENTRELEASE High 2. Medium Nightly builds of pulpcore are failing daviddavis fao89 Actions
6424 CertGuard Issue CLOSED - CURRENTRELEASE Low 2. Medium An expired client RHSM Certificate should be denied bmbouter bmbouter Actions
6546 CertGuard Issue CLOSED - CURRENTRELEASE Normal 2. Medium Docs don't mention the need to install `rhsm` as an optional dependency bmbouter bmbouter Actions
(1-100/6933) Per page: 25, 50, 100

Also available in: Atom CSV PDF

Please register to add an issue