Project

Profile

Help

Verification Required

Apply Clear

# Project Tracker Status Priority Severity Subject Author Assignee
  (blank) 6907 Collapse all/Expand all
5522 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I can filter ImportCollection reposnse messages by date to receive limit the set of messages returned bmbouter daviddavis Actions
5555 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 2. Medium Error when uploading a collection to v3 daviddavis bmbouter Actions
5569 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Cannot poll a collection import immediately after the collection is uploaded daviddavis Actions
5571 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 4. Urgent Add the ability to filter collection versions by tag newswangerd daviddavis Actions
5572 Ansible Plugin Issue CLOSED - CURRENTRELEASE Urgent 2. Medium pulp_ansible/app/tasks/collections.py:import_collections() throws FieldError alikins daviddavis Actions
5577 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium As a user, I can update a collection to deprecate it daviddavis fao89 Actions
5579 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 3. High Add the ability to set a certification status for a collection version newswangerd fao89 Actions
5621 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Add sort parameters to Collection Version List newswangerd daviddavis Actions
5645 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Need to return deprecated status in collection versions endpoint newswangerd daviddavis Actions
5670 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Add certiication param to collection version endpoint newswangerd Actions
5711 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Unnecessary DELETE action for set_certified method romanblanco Actions
5745 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Sync throws error: "filename 'MANIFEST.json' not found" daviddavis fao89 Actions
5748 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium /pulp/api/v3/ raises 500 error daviddavis Actions
5783 Ansible Plugin Issue CLOSED - CURRENTRELEASE High 2. Medium Ansible repositories API doesn't have a /modify/ endpoint iballou bmbouter Actions
5929 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Have ansible-galaxy CLI test installing a Role from pulp_ansible bmbouter bmbouter Actions
5930 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Port ansible-galaxy CLI collection install test to be bindings based and in the 'cli' area bmbouter bmbouter Actions
5931 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Have ansible-galaxy CLI test uploading a Collection to pulp_ansible bmbouter bmbouter Actions
6116 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection sync task fails syncing from automation-hub because of 'versions_url' changes alikins Actions
6129 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium sync doesn't do anything because 'download_url' moved between galaxy v2/v3 API change alikins Actions
6132 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal [EPIC] v3 collection sync daviddavis daviddavis Actions
6188 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Add nginx and apache fragment bmbouter bmbouter Actions
6223 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Pulp configured with S3 doesn't include file type extension in Content-Disposition header chouseknecht fao89 Actions
6239 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium pulp_ansible returns 404 for import status URL with trailing slash jborean bmbouter Actions
6248 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium webserver_snippts are missing from pulp_ansible 0.2.0b9 which is supposed to have them bmbouter bmbouter Actions
6272 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Add scale testing tools bmbouter bmbouter Actions
6290 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a pulp-galaxy user, I have docs and a playbook to install pulp-galaxy using ansible-pulp bmbouter fao89 Actions
6390 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Document bindings installation on dev environment fao89 fao89 Actions
6391 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Load bindings config from pulp-smash fao89 fao89 Actions
6510 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium v3.serializers.CollectionVersionSerializer needs to include distro base_path in 'download_url' alikins fao89 Actions
6540 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As an CollectionRemote user, I can configure auth_url and token to mimic how the CLI authenticates bmbouter fao89 Actions
6648 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I can use longer urls in models for collection metadata URL fields osapryki fao89 Actions
6657 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Better error messages if collection field doesn't fit DB field length osapryki fao89 Actions
6673 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a subclasser of the collection upload viewset, I can customize the task I'm dispatching to instead of always using import_collection bmbouter fao89 Actions
6715 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Remove 'certification' flag from CollectionVersion bmbouter fao89 Actions
6718 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Stop using artifacts when importing collections fao89 fao89 Actions
6738 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I can export and import Ansible content daviddavis Actions
6760 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal Update docs to have the right roles names with underscore rather than dashes fao89 Actions
6772 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Collection Import needs to validate data with CollectionSerializer before saving bmbouter fao89 Actions
6848 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Move requirements out of setup.py fao89 Actions
6850 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Introduce release script on pulp_ansible fao89 Actions
6855 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Automation hub tarballs have invalid name formatting. osapryki osapryki Actions
6889 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Missing requirements.txt fao89 Actions
7194 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I can associate a remote with a repository daviddavis daviddavis Actions
7305 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Rename ansible type newswangerd Actions
7353 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium bindings for ansible collection are too strict on documentation field jsherril@redhat.com fao89 Actions
7368 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium ANSIBLE_CONTENT_HOSTNAME should default to pulp_installer CONTENT_ORIGIN cmeyers fao89 Actions
7396 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection sync doesn't pull all collections from hub newswangerd fao89 Actions
7397 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal Expose docs_blob information for collection versions in the API newswangerd Actions
7412 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collection Remote sync breaks when requirements.yml is added. newswangerd fao89 Actions
7428 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium pulp_ansible collection list only shows collection if highest version in repo awcrosby fao89 Actions
7434 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium The requirements file on remote is limited to 255 chars daviddavis daviddavis Actions
7435 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Galaxy V3 API pagination does not match with pulp V3 API fao89 fao89 Actions
7439 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I can sync docs_blob information for collection versions daviddavis fao89 Actions
7453 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Delete the test_file_decriptors test bmbouter bmbouter Actions
7504 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Set deprecated status on synced collections. newswangerd fao89 Actions
7512 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Seeing some collections skipped with CollectionRemote with requirements.yml (related to https://github.com/ansible/galaxy_ng/issues/437) alikins fao89 Actions
7551 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Standalone galaxy_ng syncing from cloud.ci doesn't get docs for collections (https://github.com/ansible/galaxy_ng/issues/441) alikins Actions
7572 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Make MANIFEST.json and FILES.json available in the CollectionVersion serializer in the V3 API fao89 fao89 Actions
7621 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I can copy content from one repository to another daviddavis bmbouter Actions
7632 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium CollectionVersion.contents are not being synced fao89 Actions
7643 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Token is renewed for every call fao89 bmbouter Actions
7647 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium ansible-galaxy v2 collections/{namespace}/{name} not matching with actual jborean Actions
7669 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 3. High pulp_ansible galaxy collection endpoint, wrong data on empty repo awcrosby Actions
7670 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal [EPIC] As a Galaxy V3 api user, I can sync repository metadata fao89 Actions
7686 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium requirements.yml is not compatible with ansible-galaxy fao89 daviddavis Actions
7739 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Requirement.yml code doesn't filter by version daviddavis bmbouter Actions
7740 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Syncing requirements is not handling pagination correctly daviddavis fao89 Actions
7741 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Code doesn't handle requirements.yml sources with different api versions daviddavis bmbouter Actions
7742 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Setting a remote on a repo and syncing is broken daviddavis daviddavis Actions
7751 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As an user I want to sync collections and their dependencies fao89 Actions
7767 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium pulp_ansible doesn't handle trailing slashes in URLs correctly daviddavis daviddavis Actions
7775 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Need a way to track when versions for a collection has been updated jborean fao89 Actions
7777 Ansible Plugin Refactor CLOSED - CURRENTRELEASE Normal As a developer I want collections sync machinery easier to maintain fao89 bmbouter Actions
7788 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Allow CollectionUploadViewSet subclass to set own serializer awcrosby Actions
7802 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium When I use CollectionRemote.auth_url I also need to use CollectionRemote.token and vice versa bmbouter bmbouter Actions
7821 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium When I use CollectionRemote.auth_url I also need to use CollectionRemote.token but the opposite is not true fao89 Actions
7826 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Sync breaks when it is not possible to determine the highest collection version fao89 fao89 Actions
7827 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Tag names may have more than 32 characters fao89 bmbouter Actions
7830 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Sync tries to download docs-blob on Galaxy V2 fao89 fao89 Actions
7831 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Avoid to download docs-blob when content is already saved fao89 fao89 Actions
7834 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 3. High Updated deprecation status is not included in sync awcrosby Actions
7871 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium pulp-ansible-client breaks when updating V3 collections fao89 Actions
7872 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Patching CollectionRemote raises 500 fao89 Actions
7873 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a Galaxy V3 api user, I can filter collection by name/namespace fao89 Actions
7917 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Sync breaks with 403 from Akamai fao89 Actions
7926 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Move docs site to docs.pulpproject.org bmbouter bmbouter Actions
7929 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium sync is rate limiting on akamai fao89 Actions
7939 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, the /v3/ endpoint returns the repository_version.created time bmbouter fao89 Actions
7940 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I have a new v3/metadata/collections/ endpoint returning all collections unpaginated bmbouter fao89 Actions
7941 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user, I have a new v3/metadata/collection_versions/ endpoint returning all collection_versions unpaginated bmbouter Actions
7942 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a sync user, I get no-op when possible bmbouter fao89 Actions
7949 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal As a user I want to know the ansible supported version for each collection fao89 Actions
7957 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium I can't remove auth_url from a remote newswangerd Actions
7990 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Collections V3 endpoint is raising 500 fao89 Actions
8012 Ansible Plugin Task CLOSED - CURRENTRELEASE Normal Need a way to track when versions for a collection has been updated fao89 fao89 Actions
8037 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium OpenAPI schema is not valid fao89 Actions
8039 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Duplicate error on sync when collection already exists in another repository rochacbruno fao89 Actions
8051 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Token refresh POST request is missing proxy argument. rochacbruno fao89 Actions
8076 Ansible Plugin Story CLOSED - CURRENTRELEASE Normal [EPIC] As a user, I have CLI commands for role/collection workflows fao89 Actions
8078 Ansible Plugin Issue CLOSED - CURRENTRELEASE Normal 2. Medium Make consistent pulp_ansible namespace max_length in Collection and CollectionVersion awcrosby Actions
(201-300/8336) Per page: 25, 50, 100

Also available in: Atom CSV PDF

Please register to add an issue