Project

Profile

Help

Story #954

Repository display_name field should not be set automatically by API

Added by amacdona@redhat.com over 6 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Low
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

If you create a repository without a display_name, our API populates it with the repo_id. However, if you change the repo_id, the display_name does not change, resulting in potentially surprising behavior. If display names are necessary, we should make them a required field that should be explicitly set. This behavior is documented in the CLI, but not in the API docs.

If we want to maintain the current behavior of the CLI, setting the display_name should happen there.

History

#1 Updated by bmbouter almost 3 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#2 Updated by bmbouter almost 3 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#3 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

#4 Updated by bmbouter over 1 year ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Also available in: Atom PDF