Project

Profile

Help

Issue #9278

pulp_installer fails on rsync

Added by ppicka 2 months ago. Updated about 2 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

With Vagrant 2.2.18/ansible [core 2.11.3] with use of VirtualBox when I try to clean install I got

There was an error when attempting to rsync a synced folder.
Please inspect the error message below for more info.

Host path: /Users/ppicka/devel/pulp_installer/
Guest path: /vagrant
Command: "rsync" "--verbose" "--archive" "--delete" "-z" "--copy-links" "--no-owner" "--no-group" "--rsync-path" "sudo rsync" "-e" "ssh -p 2202 -o LogLevel=FATAL   -o ControlMaster=auto -o ControlPath=/var/folders/l7/91qlz20x4270tbrzftx1sd9m0000gn/T/vagrant-rsync-20210823-13439-u63iqq -o ControlPersist=10m  -o IdentitiesOnly=yes -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -i '/Users/ppicka/devel/pulp_installer/.vagrant/machines/pulp3-source-fedora34/virtualbox/private_key'" "--exclude" ".vagrant/" "/Users/ppicka/devel/pulp_installer/" "vagrant@127.0.0.1:/vagrant"
Error: symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/default/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/packages-dynamic/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/packages-static/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/packages-upgrade/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/release-dynamic/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/release-static/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/release-upgrade/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/source-dynamic/debian-redis-server.service"
symlink has no referent: "/Users/ppicka/devel/pulp_installer/molecule/source-upgrade/debian-redis-server.service"
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1350) [sender=3.2.3]

Possible it is OSX specific.

History

#1 Updated by fao89 2 months ago

  • Category set to Installer - Moved to GitHub issues

#2 Updated by ppicka about 2 months ago

  • Status changed from NEW to CLOSED - WORKSFORME

Can't reproduce anymore.

Please register to edit this issue

Also available in: Atom PDF