Project

Profile

Help

Backport #8712

Backport "Database access is needed during collectstatic" to 3.11

Added by ekohl about 1 month ago. Updated 21 days ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Estimated time:
Triaged:
Yes
Sprint Candidate:
No
Tags:
Sprint:
Sprint 97
Quarter:

Description

#8711 can be seen as a regression fix. Backporting to 3.11 will help Katello to disable md5 content types.


Related issues

Related to Pulp - Issue #8711: Database access is needed during collectstaticCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 17082026 View on GitHub
Added by bmbouter 28 days ago

Skip allowed content checks on collectstatic

Since 9a9a06f1e37f5367e36a24b9aa3aca6ca78dab53 DB access is always needed. In later commits this was extended with additional checks.

However, collectstatic should be a fully offline operation that doesn't access the network. As such, content checking is not needed.

Doing this allows the Foreman/Katello installer to run it more freely. The alternative is to add additional ordering. However, I'd argue that this is better and also slightly faster.

backports #8711

fixes #8712

(cherry picked from commit 3669a65d07278a3c455050015893517fbb6f9871)

History

#1 Updated by ekohl about 1 month ago

  • Related to Issue #8711: Database access is needed during collectstatic added

#2 Updated by fao89 about 1 month ago

  • Assignee set to bmbouter
  • Triaged changed from No to Yes
  • Sprint set to Sprint 97

#3 Updated by pulpbot 28 days ago

  • Status changed from NEW to POST

#5 Updated by bmbouter 28 days ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#6 Updated by bmbouter 21 days ago

  • Sprint/Milestone set to 3.11.2

#7 Updated by bmbouter 21 days ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF