Project

Profile

Help

Task #864

Add connection error retry support as part of upstream/downstream automation

Added by bmbouter over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The upstream/downstream automation receives this traceback 1 out of 20ish times.

Traceback (most recent call last):
  File "pulp_packaging/ci/redmine_bugzilla.py", line 172, in <module>
    main()
  File "pulp_packaging/ci/redmine_bugzilla.py", line 83, in main
    redmine_issues = [issue for issue in redmine.issue.filter(query_id=24)]
  File "/usr/lib/python2.7/site-packages/redmine/resultsets.py", line 101, in __iter__
    self._evaluate()
  File "/usr/lib/python2.7/site-packages/redmine/resultsets.py", line 80, in _evaluate
    offset=self.manager.params.get('offset', self.offset)
  File "/usr/lib/python2.7/site-packages/redmine/managers.py", line 60, in retrieve
    response = self.redmine.request('get', self.url, params=dict(self.params, limit=limit, offset=offset))
  File "/usr/lib/python2.7/site-packages/redmine/__init__.py", line 117, in request
    response = getattr(requests, method)(url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 68, in get
    return request('get', url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 50, in request
    response = session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 464, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 576, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 415, in send
    raise ConnectionError(err, request=request)
requests.exceptions.ConnectionError: ('Connection aborted.', error(110, 'Connection timed out'))

The upstream/downstream automation should be adjusted so that when query_id=24 is fetched, it catches the ConnectionError and retries up to 5 times.

History

#1 Updated by bmbouter over 5 years ago

I opened a support ticket (ticket ID [#204641][1d6fb1]) with plan.io. The error is caused by their side closing the connection. This workaround should not be implemented until we know they are not able to fix the issue on their side.

#2 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

#3 Updated by bmbouter over 1 year ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#4 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF