Project

Profile

Help

Issue #8284

pulp2content call with "erratum" as a parameter causes 500 <fixed by reset, probably difficult to reproduce>

Added by iballou 10 months ago. Updated 9 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Quarter:

Description

The following API call causes a 500:

Feb 19 15:39:30 centos7-katello-devel-2 pulpcore-api: - - [19/Feb/2021:15:39:30 +0000] "GET /pulp/api/v3/pulp2content/?limit=2000&offset=0&pulp2_content_type_id=erratum&pulp2_last_updated__gt=0 HTTP/1.1" 500 27 "-" "OpenAPI-Generator/0.7.0/ruby"

It works just fine with "rpm", however.

I noticed this issue on 0.6.0 and 0.7.0. I'm on pulp-rpm 3.8.0 and pulpcore 3.9.0.

Unfortunately there was no stack trace to go along with the 500.

The issue went away after I reset my environment. I am not sure how the issue could be reproduced since I bet it was related to stale data in my aging pulpcore database. I'm leaving this bug here in case someone hits it in the future.

History

#1 Updated by ttereshc 9 months ago

  • Status changed from NEW to CLOSED - WORKSFORME

I also can't reproduce it. If anyone runs into it please [re-]open issue or leave a comment here, preferably with steps to reproduce.

Please register to edit this issue

Also available in: Atom PDF