Project

Profile

Help

Issue #822

closed

api_prefix in admin.conf doesn't work

Added by igulina@redhat.com almost 8 years ago. Updated almost 4 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

pulp 2.6.1 on f20, if to change api_prefix in admin.conf from default '/pulp/api' to whatever, api and cli commands still work.

vi /etc/pulp/admin/admin.conf

  1. api_prefix=/pulp/api
    api_prefix=/abrakadabra/whatever

pulp-admin login -u admin -p admin

Successfully logged in. Session certificate will expire at Apr 6 14:05:19 2015
GMT.

curl -i -H "Accept: application/json" -X DELETE -k -u admin:admin 'https://localhost/pulp/api/v2/repositories/zoo_repo/importers/yum_importer/'

HTTP/1.1 202 Accepted
Date: Mon, 30 Mar 2015 14:06:18 GMT
Server: Apache/2.4.10 (Fedora) OpenSSL/1.0.1e-fips mod_wsgi/3.5 Python/2.7.5
Content-Encoding: utf-8
Content-Length: 172
Content-Type: application/json

{"spawned_tasks": [{"_href": "/pulp/api/v2/tasks/45e638b1-a63f-42e3-836a-3d733fd11c45/", "task_id": "45e638b1-a63f-42e3-836a-3d733fd11c45"}], "result": null, "error": null}

curl H "Accept: application/json" -X GET -k -u admin:admin 'https://localhost/pulp/api/v2/tasks/45e638b1-a63f-42e3-836a-3d733fd11c45/'|python -m json.tool % Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (6) Could not resolve host: H
curl: (6) Could not resolve host: Accept
100 782 100 782 0 0 2254 0 --:--:-- --:--:-- --:--:-- 3637
{
"_href": "/pulp/api/v2/tasks/45e638b1-a63f-42e3-836a-3d733fd11c45/",
"_id": {
"$oid": "5519585afe48105c03d5a1b3"
},
"_ns": "task_status",
"error": null,
"exception": null,
"finish_time": "2015-03-30T14:06:18Z",
"id": "5519585a99cca840162e3bf3",
"progress_report": {},
"queue": "reserved_resource_worker-0@ip-XXX",
"result": null,
"spawned_tasks": [],
"start_time": "2015-03-30T14:06:18Z",
"state": "finished",
"tags": [
"pulp:repository:zoo_repo",
"pulp:repository_importer:yum_importer",
"pulp:action:delete_importer"
],
"task_id": "45e638b1-a63f-42e3-836a-3d733fd11c45",
"task_type": "pulp.server.managers.repo.importer.remove_importer",
"traceback": null,
"worker_name": "reserved_resource_worker-0@ip-XXX"
}


Related issues

Is duplicate of Pulp - Issue #1844: pulp-admin --config and/or api_prefix option appears to be ignoredCLOSED - CURRENTRELEASEamacdona@redhat.comActions
Actions #1

Updated by mhrivnak almost 8 years ago

  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes
  • Tags Easy Fix added
Actions #2

Updated by mhrivnak almost 7 years ago

  • Is duplicate of Issue #1844: pulp-admin --config and/or api_prefix option appears to be ignored added
Actions #3

Updated by mhrivnak almost 7 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #4

Updated by bmbouter almost 4 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF