Project

Profile

Help

Issue #8005

closed

allow setting a "name" (i.e. description) for a repo

Added by thm almost 2 years ago. Updated about 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

The generated config.repo files lack a name = entry. The intention of this field is to hold a one-line description of the repo. When it is missing, yum/dnf issues a warning like this: Repository 'foo' is missing name in configuration, using id.

To suppress such warnings, it would be nice if one could set an attribute to an pulp rpm distribution that is used to fill that field when creating config.repo.

(Note there's potential for some confusion, because there's already a 'name' parameter to a pulp rpm distribution, that is used to fill the [repoid] section header. It probably should have been named 'repoid' instead of 'name'. As this is not going to change though, the new attribute requested in this ticket could e.g. be named 'description'.)


Related issues

Related to RPM Support - Issue #8004: limit allowed characters for rpm distribution nameCLOSED - DUPLICATEActions
Actions #1

Updated by dalley almost 2 years ago

  • Triaged changed from No to Yes
Actions #2

Updated by ggainey almost 2 years ago

From freenode:#pulp-rpm 17-DEC:

<dalley> alright.  first issue https://pulp.plan.io/issues/8005
<ppicka> imo we can have this but question if one time option or keep it with publication?
<ggainey> interesting issue
<ipanova> +1 to accept
<dalley> shouldn't we just forward the name of the repository to the generated .repo file?
<ggainey> ppicka: off the top of my head - this is for a repo-config. If it can change per-publication, what happens on the clients that know/knew the 'old' name?
<dalley> well, that might get tricky if you use multiple versions of the same repo as different repos. but I don't see why you would have one box subscribed to multiple versions
<ppicka> ggainey: good question, have never run into such situation
<ggainey> actually, you know what, we don't need to design this here. I think this is a sound request, let's make it a story and accept and then design in the ticket
<ipanova> i think forwarding the name of the repo should be ok when generating that config file
<ggainey> the name-collision is a little painful
<dalley> +1
<ppicka> I like idea of one time +1
<ggainey> the name? or the repo description? because description looks more like what foo.repo:name= looks like
<ggainey> ie, for fedora-cisco-openh264 repo, name=Fedora $releasever openh264 (From Cisco) - $basearch
<ggainey> anyway, I'll stop designing in IRC :)
Actions #3

Updated by dalley almost 2 years ago

  • Related to Issue #8004: limit allowed characters for rpm distribution name added
Actions #4

Updated by dalley about 1 year ago

  • Status changed from NEW to CLOSED - DUPLICATE

Closed as duplicate of https://pulp.plan.io/issues/9438

What we ended up doing, is having name=... value be the same as the [...] value. I'm not sure if that's the ideal solution, but it should at least suppress the warning.

@thm if you think it could still be improved, you can file a new issue or edit this one and ping me to reopen it.

Also available in: Atom PDF