Project

Profile

Help

Issue #7764

Cannot sync python pulp remote while trying to sync all the PyPI packages

Added by swaroop.vasireddy 8 months ago. Updated 6 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Python:
Platform Release:
Target Release - Python:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Hello, I hit a weird issue where when trying to sync the remote with repository the created resource is showing null value.

The exact commands are ran from the command line are attached to this issue.

[root@pulpvm0 ~]# http $BASE_ADDR$TASK_URL| jq -r '.created_resources | first' null

PULP3 error.docx (13.6 KB) PULP3 error.docx swaroop.vasireddy, 10/28/2020 07:44 PM
250

History

#1 Updated by dalley 8 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to gerrod

gerrod assigning to you since you mentioned you were looking into it.

#2 Updated by dalley 6 months ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

swaroop.vasireddy Do you happen to know which version of pulp_python you were using? For the older betas prior to, I believe, beta 12, this would be expected behavior as we didn't have a way to ask PyPI for all packages, they had to be manually included.

After beta 12, it should work. And we can't reproduce it.

If you're still experiencing this even with a newer release of pulp_python, please re-open this issue and we'll take another look.

Also available in: Atom PDF