Project

Profile

Help

Task #7536

Add support for ALLOWED_CONTENT_CHECKSUMS

Added by daviddavis 10 months ago. Updated 8 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

A couple use cases:

  • The migration should alert users if they try to upgrade a repository that's using a checksum not in ALLOWED_CONTENT_CHECKSUMS
  • Not sure if the migration plugin calculates checksums but if so, the migration should only use ones in ALLOWED_CONTENT_CHECKSUMS

There may be other use cases too?


Related issues

Related to Pulp - Story #5216: As a user, I can configure which checksum types I want to use in PulpCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Migration Plugin - Task #7782: Ensure migration plugin runs in FIPS mode and respects the ALLOWED_CONTENT_CHECKSUMS configuraitonCLOSED - COMPLETE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by daviddavis 10 months ago

  • Related to Story #7487: As a user, I'm prevented from changing ALLOWED_CONTENT_CHECKSUMS if I already have content in my DB added

#2 Updated by daviddavis 10 months ago

  • Related to deleted (Story #7487: As a user, I'm prevented from changing ALLOWED_CONTENT_CHECKSUMS if I already have content in my DB)

#3 Updated by daviddavis 10 months ago

  • Related to Story #5216: As a user, I can configure which checksum types I want to use in Pulp added

#4 Updated by daviddavis 8 months ago

  • Is duplicate of Task #7782: Ensure migration plugin runs in FIPS mode and respects the ALLOWED_CONTENT_CHECKSUMS configuraiton added

#5 Updated by daviddavis 8 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF