Project

Profile

Help

Issue #7514

Pulp 3 - Information request to force specific pulpcore + plugin versions in Ansible Pulp intaller

Added by swisscom about 1 month ago. Updated about 1 month ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Assignee:
-
Category:
Installer
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Dear support,

I'd like to upgrade my Pulp 3 to the latest possible version. Pulpcore v. 3.6.3 has been released but some plugins like pulp-rpm are not yet compatible with 3.6.3 (pulp-rpm is currently supporting 3.6.2). I found in the documentation that we can force a certain pulpcore + plugins version in the playbook file but I did not find any example where to put the "version" attribute. Would it be possible to give me a playbook example where the version of pulpcore + pulp-rpm are forced ?

Thanks a lot for your support

History

#1 Updated by mdepaulo@redhat.com about 1 month ago

  • Project changed from RPM Support to Pulp
  • Category set to Installer
  • Status changed from NEW to CLOSED - NOTABUG

Hi Swisscom,

We are working on improving this area of the installer; tooling to make it much easier to identify and install compatible versions of plugins.

In the meantime, here is an example:

Follow this guide: https://pulp-installer.readthedocs.io/en/latest/quickstart/#example-playbook-for-installing-plugins but:

For step 1: ansible-galaxy collection install pulp.pulp_installer:3.6.3-1

(That version will upgrade pulpcore to 3.6.3 specifically. The installer has been updated with a post-release, so the installer is 3.6.3-1 .)

For step 3, this playbook. Note that it will only upgrade your install if pulp-rpm is the only plugin installed. If you have other plugins installed, bout must specify them:

---
- hosts: all
  vars:
    pulp_settings:
      secret_key: << YOUR SECRET HERE >>
      content_origin: "https://{{ ansible_fqdn }}"
    pulp_default_admin_password: << YOUR PASSWORD HERE >>
    pulp_install_plugins:
      # galaxy-ng: {}
      # pulp-ansible: {}
      # pulp-certguard: {}
      # pulp-container: {}
      # pulp-cookbook: {}
      # pulp-deb: {}
      # pulp-file: {}
      # pulp-gem: {}
      # pulp-maven: {}
      # pulp-npm: {}
      # pulp-python: {}
      pulp-rpm:
        version: "3.6.2"
  roles:
    - pulp.pulp_installer.pulp_all_services
  environment:
    DJANGO_SETTINGS_MODULE: pulpcore.app.settings

Also, pulp-rpm 3.6.2 is the latest version, and it is actually compatible with pulpcore 3.6.3. The pulp-rpm 3.6 branch is compatible with the pulpcore 3.6 branch.

Also, the installer would prevent you from upgrading (throw an error early on, before messing up your Pulp installation) if you tried to install an incompatible version of pulp-rpm (or any other plugin) on top of pulpcore's version prescribed by the installer's version. (This is a feature we added months ago.)

I'm going to close this ticket, but feel free to re-open it if you have any further questions.

-Mike

#2 Updated by fao89 about 1 month ago

The pulp-rpm 3.6.2 is compatible with pulpcore 3.6.3: https://github.com/pulp/pulp_rpm/blob/3.6.2/requirements.txt#L6

An easy way for checking the pulpcore compatibility is through: https://pypi.org/project/pulpcore-releases/

Please register to edit this issue

Also available in: Atom PDF