Project

Profile

Help

Issue #7479

pulp_installer source-upgrade CI is failing on pkg_resources.ContextualVersionConflict

Added by mdepaulo@redhat.com 20 days ago. Updated 19 days ago.

Status:
NEW
Priority:
Normal
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

This occurs in debian-10 when running collect static after pulp_devel, not when running it after installing pulp via pulp_all_services.

It started occurring on daily CI and pull requests on 2020-09-8. I re-ran the overnight CI from the prior day (which originally succeeded), and when it did, it failed.

This error stands out as a dependency issue. Sometimes a package other than toml is listed though:

pkg_resources.ContextualVersionConflict: (toml 0.10.1 (/usr/local/lib/pulp/lib/python3.7/site-packages), Requirement.parse('toml<=0.10.0'), {'dynaconf'})

https://github.com/pulp/pulp_installer/runs/1091080108?check_suite_focus=true#step:7:1467

Full error:

    RUNNING HANDLER [pulp_common : Collect static content] *************************
    Wednesday 09 September 2020  12:42:43 +0000 (0:00:02.148)       0:08:16.417 ***
fatal: [debian-10]: FAILED! => {
    "changed": true, 
    "cmd": [
        "/usr/local/lib/pulp/bin/django-admin", 
        "collectstatic", 
        "--noinput", 
        "--link"
    ], 
    "delta": "0:00:00.358256", 
    "end": "2020-09-09 12:42:43.925665", 
    "rc": 1, 
    "start": "2020-09-09 12:42:43.567409"
}

STDERR:

Traceback (most recent call last):
  File "/usr/local/lib/pulp/bin/django-admin", line 8, in <module>
    sys.exit(execute_from_command_line())
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/django/core/management/__init__.py", line 381, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/django/core/management/__init__.py", line 325, in execute
    settings.INSTALLED_APPS
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/django/conf/__init__.py", line 79, in __getattr__
    self._setup(name)
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/django/conf/__init__.py", line 66, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/django/conf/__init__.py", line 157, in __init__
    mod = importlib.import_module(self.SETTINGS_MODULE)
  File "/usr/lib/python3.7/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
  File "<frozen importlib._bootstrap>", line 983, in _find_and_load
  File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/pulpcore/app/settings.py", line 76, in <module>
    plugin_app_config = entry_point.load()
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2410, in load
    self.require(*args, **kwargs)
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2433, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/usr/local/lib/pulp/lib/python3.7/site-packages/pkg_resources/__init__.py", line 791, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (toml 0.10.1 (/usr/local/lib/pulp/lib/python3.7/site-packages), Requirement.parse('toml<=0.10.0'), {'dynaconf'})


MSG:

non-zero return code
    changed: [fedora-31]

History

#1 Updated by mdepaulo@redhat.com 20 days ago

  • Assignee set to mdepaulo@redhat.com

#2 Updated by mdepaulo@redhat.com 20 days ago

  • Triaged changed from No to Yes

#3 Updated by mdepaulo@redhat.com 20 days ago

dynaconf 2.2.2 is getting installed by the end, and it requires toml <= 0.10.0 https://github.com/rochacbruno/dynaconf/blob/2.2.2/setup.py#L50

#4 Updated by mdellweg 19 days ago

Pip was recently upgraded (maybe that is related):

https://pypi.org/project/pip/#history

#5 Updated by fao89 19 days ago

it is a conflict between black and dynaconf

black requires toml>=0.10.1 https://github.com/psf/black/blob/master/setup.py#L73

Please register to edit this issue

Also available in: Atom PDF