Project

Profile

Help

Issue #739

Not a directory error when publishing

Added by jgreguske over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
High
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Docker:
master
Platform Release:
Target Release - Docker:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When publishing a docker repository, I get an error.

Here are details of the repository

{'_href': '/pulp/api/v2/repositories/redhat-openshift3_beta-ose-deployer/',
 '_id': {'$oid': '54f8da6baa9ea96c3522e6d7'},
 '_ns': 'repos',
 'content_unit_counts': {'docker_image': 9},
 'description': 'Handles deploying containers when new versions are available or triggered',
 'display_name': 'redhat-openshift3_beta-ose-deployer',
 'distributors': [{'_id': {'$oid': '54f8da6baa9ea96c3522e6da'},
                   '_ns': 'repo_distributors',
                   'auto_publish': True,
                   'config': {'protected': False,
                              'redirect-url': 'http://internal.redhat.server.com/containers/registry/',
                              'repo-registry-id': 'openshift3_beta/ose-deployer'},
                   'distributor_type_id': 'docker_distributor_web',
                   'id': 'docker_web_distributor_name_cli',
                   'last_publish': '2015-03-06T13:44:07Z',
                   'repo_id': 'redhat-openshift3_beta-ose-deployer',
                   'scheduled_publishes': []},
                  {'_id': {'$oid': '54f8da6baa9ea96c3522e6d9'},
                   '_ns': 'repo_distributors',
                   'auto_publish': True,
                   'config': {'protected': False,
                              'redirect-url': 'http://internal.redhat.server.com/containers/registry/',
                              'repo-registry-id': 'openshift3_beta/ose-deployer'},
                   'distributor_type_id': 'docker_distributor_export',
                   'id': 'docker_export_distributor_name_cli',
                   'last_publish': '2015-03-06T13:44:00Z',
                   'repo_id': 'redhat-openshift3_beta-ose-deployer',
                   'scheduled_publishes': []}],
 'id': 'redhat-openshift3_beta-ose-deployer',
 'importers': [{'_id': {'$oid': '54f8da6baa9ea96c3522e6d8'},
                '_ns': 'repo_importers',
                'config': {},
                'id': 'docker_importer',
                'importer_type_id': 'docker_importer',
                'last_sync': None,
                'repo_id': 'redhat-openshift3_beta-ose-deployer',
                'scheduled_syncs': []}],
 'last_unit_added': '2015-03-05T22:36:28Z',
 'last_unit_removed': None,
 'notes': {'_repo-type': 'docker-repo'},
 'scratchpad': {'tags': [{'image_id': 'c6bc2d82fcfd0c7a5a9560970b520dc7dddbc477bd97065aeb421b1749c8b73b',
                          'tag': 'latest'},
                         {'image_id': 'c6bc2d82fcfd0c7a5a9560970b520dc7dddbc477bd97065aeb421b1749c8b73b',
                          'tag': 'v0.3'}]}}

Attempting to publish with the REST API (or CLI) leads to a traceback in the spawned subtask:

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 240, in trace_task
    R = retval = fun(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 337, in __call__
    return super(Task, self).__call__(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 437, in __protected_call__
    return self.run(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/publish.py", line 98, in publish
    transfer_repo, conduit, call_config)
  File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/publish.py", line 130, in _do_publish
    publish_report = publish_repo(transfer_repo, conduit, call_config)
  File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 492, in wrap_f
    return f(*args, **kwargs)
  File "/opt/pulp_docker/plugins/pulp_docker/plugins/distributors/distributor_web.py", line 123, in publish_repo
    return self._publisher.publish()
  File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 508, in publish
    return self.process_lifecycle()
  File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 457, in process_lifecycle
    super(PluginStep, self).process_lifecycle()
  File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 122, in process_lifecycle
    step.process()
  File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 180, in process
    self._process_block()
  File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 215, in _process_block
    self.process_main()
  File "/usr/lib/python2.6/site-packages/pulp/plugins/util/publish_step.py", line 776, in process_main
    shutil.copytree(timestamp_master_location, publish_location, symlinks=True)
  File "/usr/lib64/python2.6/shutil.py", line 136, in copytree
    names = os.listdir(src)
OSError: [Errno 20] Not a directory: '/var/lib/pulp/published/docker/master/redhat-openshift3_beta-ose-deployer/1425648629.96/redhat-openshift3_beta-ose-deployer.json'

History

#1 Updated by mhrivnak over 5 years ago

  • Sprint/Milestone deleted (13)

#2 Updated by mhrivnak over 5 years ago

It looks like when you filed this issue, you scheduled it onto our March sprint. Please don't do that. :)

#3 Updated by dkliban@redhat.com over 5 years ago

  • Priority changed from Normal to High
  • Severity changed from High to Medium
  • Triaged changed from No to Yes

#4 Updated by mhrivnak over 5 years ago

Is this a brand new pulp, or an upgrade?

How did you get this docker repo in? Upload? Sync?

#5 Updated by jgreguske over 5 years ago

mhrivnak wrote:

Is this a brand new pulp, or an upgrade?

How did you get this docker repo in? Upload? Sync?

New instance of Pulp 2.5.3 Repositories were created manually, and then images were uploaded to them. All interactions were done over the REST API. I'll send you the images I used elsewhere.

#6 Updated by mhrivnak over 5 years ago

For those playing along at home, Jay is working through multiple issues where the deployed pulp code was not the expected version. At this point, it seems unlikely that this is a pulp bug. But, Jay will report back once he can try with an legit deployment.

#7 Updated by bmbouter over 5 years ago

  • Severity changed from Medium to 2. Medium

#8 Updated by bmbouter over 5 years ago

  • Version deleted (2.5)
  • Version - Docker set to master

#9 Updated by ipanova@redhat.com about 5 years ago

  • Status changed from NEW to CLOSED - WORKSFORME

Was not able to reproduce, in case this issue appears again, please re-open.

#10 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF