Project

Profile

Help

Issue #734

Asynchronous attach in the pulp agent causes unwanted race condition

Added by jortel@redhat.com almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.6 Beta
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

As part of the work to delete the agent queues the pulp agent was changed to asynchronously validate registration and attach to the broker. This introduced a race condition race condition which can result in RMI requests failing because the plugin has not been completely initialized before the gofer scheduler is started.

History

#1 Updated by jortel@redhat.com almost 7 years ago

  • Status changed from NEW to POST

#2 Updated by jortel@redhat.com almost 7 years ago

  • Status changed from POST to MODIFIED

#3 Updated by dkliban@redhat.com almost 7 years ago

  • Status changed from MODIFIED to 5

#4 Updated by jortel@redhat.com almost 7 years ago

This can be verified by simply registering a consumer and noting the 'attached' message in the log. Just needs to be regression tested.

#5 Updated by pthomas@redhat.com almost 7 years ago

  • Status changed from 5 to 6

verified.

The agent registration and consumer has been regression tested.

#6 Updated by bmbouter almost 7 years ago

  • Severity changed from High to 3. High

#7 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#9 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF