Project

Profile

Help

Issue #7330

Failure during generate of token authentication private key

Added by ipanova@redhat.com over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 79
Quarter:

Description

I get this error when i try to provision box pulp2-nightly-pulp3-source-centos7

TASK [pulp_api : Generate token authentication private key] ********************
fatal: [pulp2-nightly-pulp3-source-centos7]: FAILED! => {
    "changed": false
}

MSG:

value of curve must be one of: secp384r1, secp521r1, secp224r1, secp192r1, secp256k1, brainpoolP256r1, brainpoolP384r1, brainpoolP512r1, sect571k1, sect409k1, sect283k1, sect233k1, sect163k1, sect571r1, sect409r1, sect283r1, sect233r1, sect163r2, got: secp256r1


We should select a curve that is compatible on centos, fedora,etc boxes

History

#1 Updated by fao89 over 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 79

#2 Updated by bmbouter over 1 year ago

  • Category set to Installer - Moved to GitHub issues

#3 Updated by mdepaulo@redhat.com over 1 year ago

  • Assignee set to fao89

#4 Updated by fao89 over 1 year ago

I did not get this error on my box:

(pulp) [vagrant@pulp2-nightly-pulp3-source-centos7 ~]$ cat /etc/centos-release
CentOS Linux release 7.8.2003 (Core)

If you have an older version, please do:

vagrant box update centos7

#5 Updated by ipanova@redhat.com over 1 year ago

  • Status changed from NEW to CLOSED - WORKSFORME

The box was up to date, however I have upgraded my fedora which was couple of versions behind and I could not reproduce this issue anymore. Closing.

#6 Updated by fao89 over 1 year ago

  • Assignee deleted (fao89)

Also available in: Atom PDF