Project

Profile

Help

Issue #721

Export ISO file retention Limitation.

Added by bvijaycom over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - NOTABUG
Priority:
High
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Hi Team,

Today I have created pulp server in DMZ subnet and from our master server tried to export as an ISO file. So that from disconnected server I can recreate whenever I need to replicate. However the problem is pulp is always keep n version. Second time if we execute export command the current exported ISO file and directory getting deleted before the new ISO file creation. Is there any way to put retention files (I mean number files) on my own?

My pulp version is

[root@server1]# rpm -q pulp-server
pulp-server-2.5.3-1.el7.noarch

I understand that this export to different directory can be achieved through --export-dir tag.However i just tested the same command and added with --export-dir option.

Now i have 2 issues

1. I have created directory under / called test.I have changed the ownership to apache:apache and executed the export command with --export-dir pointing to this directory.I have received permission denied error.Is there any limitation in pulp that ,pulp will understand only inside /var/lib/pulp directory ?

2. However now i have created the directory called export inside /var/lib/pulp/ and changed the ownership to apache:apache. Now if i run export command pointing to this directory,only rpm's are getting downloaded instead of single ISO file.

Now i am looking for some solutions for the below scenarios in the future releases...

1. Through --export-dir option if we give external directory it should be allowed in pulp for creating ISO file.
2. If i give /var/lip/pulp/export directory in --export-dir tag,why instead ISO single file rpm's are getting downloaded.
3. Also if the customer wants to retain n number of iso exported files under /var/lib/pulp/published/yum/master/export_distributor/ directory itself then there should be command option

Here i have attached the log file.

Thanks,
BVIJAY


Related issues

Has duplicate RPM Support - Issue #326: Export ISO file retention Limitation.CLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by bvijaycom over 5 years ago

  • Copied from Issue #326: Export ISO file retention Limitation. added

#2 Updated by bcourt over 5 years ago

Hi, for the use of the /test directory, is it possible you have selinux enabled and have not added an selinux permissions for the apache user on the /test directory?

#3 Updated by bvijaycom over 5 years ago

Hi,

I have changed the selinux similer to /var/lib/pulp for /test directory.Now
I am able to execute the export command.However in /test directory there is
no ISO file getting created.The RPM files getting downloaded.

Here the logs are

[root@test1053 1425327013.27]# pwd
/var/lib/pulp/published/yum/master/export_distributor/custom_repo1/1425327013.27
[root@test1053 1425327013.27]# ls ltr
total 1468
-rw-r--r-
. 1 apache apache 1501184 Mar 2 15:10
custom_repo1-2015-03-02T15.10-01.iso
[root@test1053 1425327013.27]# cd /test
[root@test1053 test]# ls ltr
total 4
drwxr-xr-x. 3 apache apache 59 Mar 2 15:09 custom_repo1
-rw-r--r-
. 1 apache apache 12 Mar 2 15:09 listing
[root@test1053 test]# cd custom_repo1/
[root@test1053 custom_repo1]# ls ltr
total 1100
-rw-r--r-
. 1 apache apache 1122292 Feb 25 16:41
engrampa-1.8.1-1.el7.x86_64.rpm
drwxr-x---. 2 apache apache 4096 Mar 2 15:09 repodata
[root@test1053 custom_repo1]# ls -ldZ /test/
drwxrwxrwx. apache apache unconfined_u:object_r:httpd_sys_rw_content_t:s0
/test/
[root@test1053 custom_repo1]# ls -ldZ /var/lib/pulp/
drwxr-xr-x. apache apache system_u:object_r:httpd_sys_rw_content_t:s0
/var/lib/pulp/
[root@test1053 custom_repo1]#

On Tue, Mar 3, 2015 at 1:27 AM, Pulp <> wrote:

#4 Updated by bmbouter over 5 years ago

  • Triaged changed from No to Yes

#5 Updated by bmbouter over 5 years ago

  • Copied from deleted (Issue #326: Export ISO file retention Limitation.)

#6 Updated by bmbouter over 5 years ago

  • Has duplicate Issue #326: Export ISO file retention Limitation. added

#7 Updated by bmbouter over 5 years ago

  • Severity changed from High to 3. High

#8 Updated by ipanova@redhat.com about 5 years ago

  • Status changed from NEW to CLOSED - NOTABUG

I saw that in this bug report were listed three issues:

1. Through --export-dir option if we give external directory it should be allowed in pulp for creating ISO file.
2. If i give /var/lip/pulp/export directory in --export-dir tag,why instead ISO single file rpm's are getting downloaded.
3. Also if the customer wants to retain n number of iso exported files under /var/lib/pulp/published/yum/master/export_distributor/ directory itself then there should be command option

So,
- first one was solved by reporter due to selinux permissions
- second, the '--export-dir' was not understood right. If this options is specified then the content will be exported to the that directory, instead of creating the ISO. So behaviour is correct:

  --export-dir   - the full path to a directory; if specified, the repository
                   will be exported to the given directory instead of being
                   placed in ISOs and published via HTTP or HTTPS

- And for the last one I will open a separate issue as RFE

Closing this as notabug, if you think differently please reopen.

#9 Updated by ipanova@redhat.com about 5 years ago

Link for ISOs retention RFE https://pulp.plan.io/issues/1324

#10 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF