Project

Profile

Help

Issue #7184

closed

All content is migrated even if only one repository out of many is migrated

Added by dalley almost 2 years ago. Updated almost 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

If I have 230,000 content in Pulp 2 and I try to migrate just the CentOS7 repo w/ 10,000 within, all 230,000 content are migrated.

IIRC this is "intended behavior" but we should perhaps think about ways to mitigate it a little bit?

Actions #1

Updated by dalley almost 2 years ago

  • Description updated (diff)
Actions #2

Updated by ttereshc almost 2 years ago

It is intended. The justification is/was that migrating content only from a subset of repos in a most common case (all repos or the majority are migrated) is not efficient. If someone wants to migrate only a very small subset of repos, they can just recreate those in Pulp 3.

Let's discuss more reasons here. Though I think we have similar issue filed already.

Actions #4

Updated by dalley almost 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

Also available in: Atom PDF