Project

Profile

Help

Issue #693

close access to old docs and add support of pulp versions to new docs

Added by igulina@redhat.com almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Pulp 2
Sprint:
Quarter:

Description

1) Since new docs are here http://pulp.readthedocs.org/en/latest/

We suggest to disable
http://pulp-user-guide.readthedocs.org
http://pulp-dev-guide.readthedocs.org

since it's not up to date, that might confuse users.

2) It's not possible to switch between pulp versions on http://pulp.readthedocs.org/en/latest/
as it is possible on http://pulp-user-guide.readthedocs.org

+ This bug was cloned from Bugzilla Bug #1191560 +

Associated revisions

Revision cb403757 View on GitHub
Added by dkliban@redhat.com almost 7 years ago

Added message about new documentation

closes #693

Revision b7f02b05 View on GitHub
Added by dkliban@redhat.com almost 7 years ago

Added message about new documentation

Closes #693

Revision ea439383 View on GitHub
Added by dkliban@redhat.com almost 7 years ago

Added message about new documentation

closes #693

Revision 99b1bf1e View on GitHub
Added by bmbouter almost 7 years ago

Deletes all docs so users will clearly see the warning banner

re #693

Revision 8b4ae853 View on GitHub
Added by bmbouter almost 7 years ago

Deletes all docs so users will see the warning banner

re #693

Revision 195270d5 View on GitHub
Added by bmbouter almost 7 years ago

Deletes all docs so users will see the warning banner

closes #693

History

#1 Updated by bmbouter almost 7 years ago

Pulp < 2.6.0 will continue to be hosted in their current location.

http://pulp-user-guide.readthedocs.org
http://pulp-dev-guide.readthedocs.org

Pulp >= 2.6.0 will be hosted at pulp.readthedocs.org. Currently 2.6.0 is not released so the only available builder on pulp.readthedocs.org is named 'latest' which builds from the master branch. When 2.6.0 is released a new builder will be made for 2.6.0. Any new versions >= 2.6.0 will have builders so over time you will be able to switch Pulp versions at pulp.readthedocs.org.

The Pulp < 2.6.0 cannot live under the pulp.readthedocs.org due to technical sphinx reasons related to the location of the conf.py file and how RTD works.

I propose that when 2.6.0 is released, a banner is added to the < 2.6.0 docs sites indicating that it is an out of date version. We cannot take down those old sites because some users still use those versions.

Other thoughts or suggestions are welcome. If you agree with the banner idea we could use this bug to track that activity as part of the 2.6.0 release.

+ This comment was cloned from Bugzilla #1191560 comment 1 +

#2 Updated by igulina@redhat.com almost 7 years ago

Many thanks for the info why it's not possibly to unify doc sources.

The Banner is a good solution. Thanks!

+ This comment was cloned from Bugzilla #1191560 comment 2 +

#3 Updated by mhrivnak almost 7 years ago

We should also remove the "latest" build from the old doc sites, so the only option is to be viewing a specific released version.

+ This comment was cloned from Bugzilla #1191560 comment 3 +

#4 Updated by jortel@redhat.com almost 7 years ago

Implement after 2.6.0 is released.

+ This comment was cloned from Bugzilla #1191560 comment 4 +

#5 Updated by bmbouter almost 7 years ago

  • Category deleted (1)
  • Tags Documentation added

Documentation is now a Tag not a Category.

#6 Updated by bmbouter almost 7 years ago

  • Severity changed from High to 3. High

#7 Updated by dkliban@redhat.com almost 7 years ago

  • Status changed from NEW to MODIFIED
  • % Done changed from 0 to 100

#11 Updated by igulina@redhat.com almost 7 years ago

  • Status changed from 5 to 6

Thank you! =)

#12 Updated by igulina@redhat.com almost 7 years ago

  • Status changed from 6 to ASSIGNED

The banner was placed only on the main pages, however if to open links with 'latest' in url, they are not latest in fact and there is no banner about that

For example:
http://pulp-user-guide.readthedocs.org/en/latest/installation.html

My shame I didn't see it before.

#13 Updated by bmbouter almost 7 years ago

  • Assignee set to bmbouter

#14 Updated by bmbouter almost 7 years ago

QE should verify two things for each of the list of URLs below.

(1) that a banner containing a link to the correct new docs exist.
(2) That it has a title ie: Pulp RPM Technical Reference
(3) That all other pages of docs are deleted and are expected to produce a 404 error.

The URLs:

http://pulp-user-guide.readthedocs.org/en/latest/
http://pulp-dev-guide.readthedocs.org/en/latest/
http://pulp-rpm-user-guide.readthedocs.org/en/latest/
http://pulp-rpm-dev-guide.readthedocs.org/en/latest/
http://pulp-puppet-user-guide.readthedocs.org/en/latest/
http://pulp-puppet-dev-guide.readthedocs.org/en/latest/

#15 Updated by bmbouter almost 7 years ago

  • Status changed from ASSIGNED to MODIFIED

#16 Updated by bmbouter almost 7 years ago

  • Status changed from MODIFIED to 5

#17 Updated by igulina@redhat.com almost 7 years ago

  • Status changed from 5 to 6

Great! \(^.^)/

#18 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#20 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF