Project

Profile

Help

Story #69

As a user, I'd like to be able to upgrade pulp packages on consumers using pulp

Added by Anonymous over 6 years ago. Updated about 1 month ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Users would like to upgrade pulp packages on consumers using Pulp.  This will require API compatibility and the ability for the Pulp server to initiate restarted the agent.The flow:1. Upgrade the pulp server.2. Send content update request to one or more consumers.  Something like 'pulp-admin rpm consumer update run --consumer-id=ABC -n \*pulp\*'And have it work.

History

#1 Updated by rbarlow over 6 years ago

  • Project changed from 22 to Pulp

#2 Updated by amacdona@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - WONTFIX

#3 Updated by bmbouter about 2 years ago

  • Tags Pulp 2 added

#4 Updated by rareskyfour about 1 month ago

For Qpid environments, to upgrade a consumer from 2.3. x –> 2.4. 0, run the command sudo yum groupupdate pulp-consumer-qpid . For RabbitMQ installations, upgrade the Pulp consumer client and agent packages without any Qpid specific dependencies using sudo yum groupinstall pulp-consumer .https://mybk-experience.onl https://www.mcdvoicesurvey.onl/

Please register to edit this issue

Also available in: Atom PDF