Project

Profile

Help

Issue #683

Pulp throws away validation error information from distributors

Added by amacdona@redhat.com almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.3
Platform Release:
2.6.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

If there are validation errors, Pulp catches it and raises an unhelpful error.

How reproducible:

Always

Steps to Reproduce:
1. Create a distributor config that will fail validation, like a docker repo with a capital letter in the repo-registry-id

Actual results:

Pulp exception occurred: PulpDataException

Expected results:

A helpful error.

Additional info:

Fixed with:
https://github.com/pulp/pulp/pull/1487/

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Description:

Packages to be added:

Comps group:

Default:

Mandatory:

Visible:

Multi-lib:

Need to be present for arches:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Description:

Packages to be added:

Comps group:

Default:

Mandatory:

Visible:

Multi-lib:

Need to be present for arches:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Description:

Packages to be added:

Comps group:

Default:

Mandatory:

Visible:

Multi-lib:

Need to be present for arches:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Description:

Packages to be added:

Comps group:

Default:

Mandatory:

Visible:

Multi-lib:

Need to be present for arches:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Description:

Packages to be added:

Comps group:

Default:

Mandatory:

Visible:

Multi-lib:

Need to be present for arches:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1187200 +


Related issues

Has duplicate Docker Support - Issue #117: Validation message for docker repo create does not make senseCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#2 Updated by amacdona@redhat.com almost 7 years ago

Originally reported as a pulp_docker bug.

https://pulp.plan.io/issues/117

+ This comment was cloned from Bugzilla #1187200 comment 2 +

#3 Updated by bmbouter almost 7 years ago

  • Triaged changed from No to Yes

#4 Updated by bmbouter almost 7 years ago

  • Has duplicate Issue #117: Validation message for docker repo create does not make sense added

#5 Updated by bmbouter almost 7 years ago

  • Severity changed from Medium to 2. Medium

#6 Updated by dkliban@redhat.com over 6 years ago

  • Platform Release set to 2.6.1

#7 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from MODIFIED to 5

#8 Updated by pthomas@redhat.com over 6 years ago

  • Status changed from 5 to 6

verified

[root@qe-blade-13 ~]# pulp-admin docker repo create --repo-id=Busybox
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

A validation error occurred.

If repo-registry-id is not specified, it will default to the id must contain
only lower case letters, integers, hyphens, periods, and may include a single
slash. Please specify a valid registry id or change the repo id.

[root@qe-blade-13 ~]# 
[root@qe-blade-13 ~]# 

<\pre>

#9 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#11 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF