Project

Profile

Help

Issue #6683

closed

treeinfo file missing from publication after a migrated kickstart is synced in pulp 3

Added by dkliban@redhat.com over 2 years ago. Updated 11 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Steps to reproduce:

  1. Create centos 7 kickstart repo in pulp 2
  2. Sync the repository in pulp 2
  3. Migrate all 'rpm' content/repositories into pulp 3
  4. View the distribution content in the browser and notice that there is a treeinfo file
  5. Sync the pulp 3 repository with the pulp 3 remote
  6. Create a new publication from the new repository version
  7. Update teh distribution
  8. View the distribution content in the browser and notice that there is NOT a treeinfo file
Actions #1

Updated by ttereshc over 2 years ago

  • Triaged changed from No to Yes
Actions #2

Updated by dalley over 1 year ago

  • Project changed from RPM Support to Migration Plugin
Actions #3

Updated by ttereshc 11 months ago

  • Status changed from NEW to CLOSED - WORKSFORME

Can't reproduce it with all the recent fixes to treeinfo management. pulpcore 3.17 and future pulp_rpm 3.17

Also available in: Atom PDF