Project

Profile

Help

Issue #6531

Advisory conflict happens when syncing a migrated repo

Added by ipanova@redhat.com over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 73
Quarter:

Description

I have migrated a repo from pulp2 that initially got synced from https://repos.fedorapeople.org/pulp/pulp/fixtures/rpm-references-updateinfo/

Then i tried to used the migrated repo's importer aka remote and sync failed

$ http GET $BASE_ADDR/pulp/api/v3/tasks/e3fc9b56-0c3d-4b86-9fca-7f2a8909cc6a/
HTTP/1.1 200 OK
Allow: GET, PATCH, DELETE, HEAD, OPTIONS
Connection: close
Content-Length: 2824
Content-Type: application/json
Date: Mon, 20 Apr 2020 17:06:15 GMT
Server: gunicorn/20.0.4
Vary: Accept, Cookie
X-Frame-Options: SAMEORIGIN

{
    "child_tasks": [],
    "created_resources": [],
    "error": {
        "description": "Incoming and existing advisories have the same id and timestamp but different and intersecting package lists. At least one of them is wrong. Advisory id: RHEA-2012:0056",
        "traceback": "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/worker.py\", line 886, in perform_job\n    rv = job.perform()\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py\", line 664, in perform\n    self._result = self._execute()\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py\", line 670, in _execute\n    return self.func(*self.args, **self.kwargs)\n  File \"/home/vagrant/devel/pulp_rpm/pulp_rpm/app/tasks/synchronizing.py\", line 167, in synchronize\n    dv.create()\n  File \"/home/vagrant/devel/pulpcore/pulpcore/plugin/stages/declarative_version.py\", line 149, in create\n    loop.run_until_complete(pipeline)\n  File \"/home/vagrant/devel/pulpcore/pulpcore/app/models/repository.py\", line 767, in __exit__\n    repository.finalize_new_version(self)\n  File \"/home/vagrant/devel/pulp_rpm/pulp_rpm/app/models/repository.py\", line 139, in finalize_new_version\n    resolve_advisories(new_version, previous_version)\n  File \"/home/vagrant/devel/pulp_rpm/pulp_rpm/app/advisory.py\", line 66, in resolve_advisories\n    previous_advisory, added_advisory\n  File \"/home/vagrant/devel/pulp_rpm/pulp_rpm/app/advisory.py\", line 139, in resolve_advisory_conflict\n    raise AdvisoryConflict(_('Incoming and existing advisories have the same id and '\n"
    },
    "finished_at": "2020-04-20T17:06:13.537381Z",
    "name": "pulp_rpm.app.tasks.synchronizing.synchronize",
    "parent_task": null,
    "progress_reports": [
        {
            "code": "parsing.comps",
            "done": 3,
            "message": "Parsed Comps",
            "state": "completed",
            "suffix": null,
            "total": 3
        },
        {
            "code": "parsing.advisories",
            "done": 4,
            "message": "Parsed Advisories",
            "state": "completed",
            "suffix": null,
            "total": 4
        },
        {
            "code": "parsing.packages",
            "done": 35,
            "message": "Parsed Packages",
            "state": "completed",
            "suffix": null,
            "total": 35
        },
        {
            "code": "downloading.metadata",
            "done": 5,
            "message": "Downloading Metadata Files",
            "state": "completed",
            "suffix": null,
            "total": null
        },
        {
            "code": "downloading.artifacts",
            "done": 0,
            "message": "Downloading Artifacts",
            "state": "completed",
            "suffix": null,
            "total": null
        },
        {
            "code": "associating.content",
            "done": 4,
            "message": "Associating Content",
            "state": "completed",
            "suffix": null,
            "total": null
        }
    ],
    "pulp_created": "2020-04-20T17:06:09.040275Z",
    "pulp_href": "/pulp/api/v3/tasks/e3fc9b56-0c3d-4b86-9fca-7f2a8909cc6a/",
    "reserved_resources_record": [
        "/pulp/api/v3/repositories/rpm/rpm/574e3ae3-079d-41f9-9b63-e71f01ff6420/",
        "/pulp/api/v3/remotes/rpm/rpm/c2d1df25-2f09-4fe1-8a7f-ce768d540e67/"
    ],
    "started_at": "2020-04-20T17:06:09.152171Z",
    "state": "failed",
    "task_group": null,
    "worker": "/pulp/api/v3/workers/4e91fcc4-cc02-482b-8998-6d9d1c45e5bc/"
}

History

#1 Updated by ipanova@redhat.com over 1 year ago

  • Description updated (diff)

#2 Updated by ipanova@redhat.com over 1 year ago

  • Description updated (diff)

#3 Updated by ttereshc over 1 year ago

  • Subject changed from Cannot sync a migrated repo that contains errata to Advisory conflict happens when syncing a migrated repo

#4 Updated by ttereshc over 1 year ago

  • Triaged changed from No to Yes

#5 Updated by ttereshc over 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc

#6 Updated by ttereshc over 1 year ago

  • Sprint set to Sprint 71

#7 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 71 to Sprint 72

#8 Updated by rchan over 1 year ago

  • Sprint changed from Sprint 72 to Sprint 73

#9 Updated by ttereshc over 1 year ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

There were various changes in the advisory conflict resolution area, maybe this issue was solved there. I can't reproduce it at the moment.

#10 Updated by ipanova@redhat.com over 1 year ago

I can confirm, i could not reproduce either anymore.

Please register to edit this issue

Also available in: Atom PDF