Project

Profile

Help

Issue #649

https://repos.fedorapeople.org/repos/pulp/pulp/rhel-pulp.repo does not work on Centos7

Added by jon@soh.re over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.5
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Description of problem:
The .repo file does not work with a fresh Centos 7 box. Specifically $releasever on Centos7 resolves as "7" where as the pulp repo is expecting it to resolve to "7Server", because of this, people are unable to follow the getting started guide on https://pulp-user-guide.readthedocs.org/en/2.5-release/installation.html.

The fix is, to edit the .repo file from $releasever to "$releasever"Server

Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:
1. Build a new Centos7 Box
2. Wget the repo
3. Yum update and watch the url fail

Actual results:
https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

Expected results:
pulp-2-stable | 3.6 kB 00:00:00
(1/2): pulp-2-stable/7/x86_64/group_gz | 521 B 00:00:00
(2/2): pulp-2-stable/7/x86_64/primary_db | 22 kB 00:00:00

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

Document URL:

Section Number and Name:

Describe the issue:

Suggestions for improvement:

Additional information:

+ This bug was cloned from Bugzilla Bug #1178241 +

History

#1 Updated by rbarlow over 5 years ago

Another option is for us to make one of 7 and 7Server a symlink to the other in our hosted repository.

+ This comment was cloned from Bugzilla #1178241 comment 1 +

#2 Updated by bmbouter over 5 years ago

This is likely a problem between Server and Workstation, not RHEL vs CentOS. I believe both RHEL and CentOS do not report the 'Server' part of the string when used with Workstation.

I think the symlink is the right approach. We should do the same for 6 and 6Server along with 5 and 5Server.

+ This comment was cloned from Bugzilla #1178241 comment 2 +

#3 Updated by bmbouter over 5 years ago

  • Tags Documentation added

#4 Updated by bmbouter over 5 years ago

  • Category deleted (1)

Documentation is now a Tag not a Category.

#5 Updated by bmbouter over 5 years ago

  • Severity changed from Low to 1. Low

#6 Updated by rbarlow over 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to rbarlow

#7 Updated by rbarlow over 5 years ago

  • Status changed from ASSIGNED to NEW
  • Assignee deleted (rbarlow)

I added symlinks manually as a workaround for the short term.

We still need our build script to make these automatically so they remain in the long term, so I am leaving this ticket open until we can address the issue permanently.

#8 Updated by bcourt over 5 years ago

The build script was updated to create the symlinks as well. Is that enough to close this issue or do we still need a centos specific .repo file?

#9 Updated by bmbouter over 5 years ago

bcourt wrote:

The build script was updated to create the symlinks as well. Is that enough to close this issue or do we still need a centos specific .repo file?

Will those symlinks work for CentOS7? Are the symlinks the same for RHEL7 and CentOS 7?

If the build script produces everything that will resolve the issue then I think it should be send to QE along with 2.6.2 and some instructions so they can verify it would be good. This assumes the build script generates everything automatically which I think is important.

#10 Updated by semyers almost 5 years ago

  • Status changed from NEW to CLOSED - WORKSFORME
  • Assignee set to semyers

I have a rhel7 and cent7 box hanging out in my libvirt env and I've got a couple minutes, so...

This has presumably been fixed since April, in this commit:
https://github.com/pulp/pulp_packaging/commit/42a88786ea427723c0c92a8ab4276270ad1423e6

You can see that both the '7' and '7Server' dirs exist in the repo:
https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/

Using the yumdownloader tool, you can see that the package urls are as described in the issue description, and that they can be downloaded with the '7' vs. '7Server' difference.

CentOS 7:

# yumdownloader -q --urls pulp-server
https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7/x86_64/pulp-server-2.7.0-1.el7.noarch.rpm
# wget -q https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7/x86_64/pulp-server-2.7.0-1.el7.noarch.rpm && echo 'The download worked!'
The download worked!
# sha256sum pulp-server-2.7.0-1.el7.noarch.rpm
193cddacabccd8d37e4c605b4191ac0845aa5339a295dcc4e80a7621796954c6  pulp-server-2.7.0-1.el7.noarch.rpm

RHEL 7:

# yumdownloader -q --urls pulp-server                                                                                                                                                         
https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7Server/x86_64/pulp-server-2.7.0-1.el7.noarch.rpm
# wget -q https://repos.fedorapeople.org/repos/pulp/pulp/stable/2/7Server/x86_64/pulp-server-2.7.0-1.el7.noarch.rpm && echo 'The download worked!'                                            
The download worked!
# sha256sum pulp-server-2.7.0-1.el7.noarch.rpm
193cddacabccd8d37e4c605b4191ac0845aa5339a295dcc4e80a7621796954c6  pulp-server-2.7.0-1.el7.noarch.rpm

#11 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF