Project

Profile

Help

Issue #640

Current master of nectar requires a newer version of python-requests

Added by bcourt almost 6 years ago. Updated almost 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Master
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description:
The current master branch of nectar will fail if run against python-requests 2.2.1. The dependency in pulp & nectar should be updated or the threaded downloader should be updated to not use the new python-requests api.

+ This bug was cloned from Bugzilla Bug #1174283 +

History

#1 Updated by amacdona@redhat.com almost 6 years ago

Barnaby, Pulp 2.6 is bundled with python-requests-2.4.3, so this should not be an issue.

Please reopen if I am incorrect.

+ This comment was cloned from Bugzilla #1174283 comment 1 +

#2 Updated by amacdona@redhat.com almost 6 years ago

https://github.com/pulp/nectar/pull/26

I see that the problem was not the built dependencies, rather the requires statement in the spec. I think that we should require at least the version that we provide.

+ This comment was cloned from Bugzilla #1174283 comment 2 +

#3 Updated by cduryee almost 6 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1174283 comment 3 +

#4 Updated by igulina@redhat.com almost 6 years ago

Failed QA

rpm -q pulp-server

pulp-server-2.6.0-0.2.beta.fc20.noarch

rpm -qR python-nectar | grep python-requests

python-requests >= 2.2.1

+ This comment was cloned from Bugzilla #1174283 comment 4 +

#5 Updated by amacdona@redhat.com almost 6 years ago

This was fixed in the nectar spec file, but not in the pulp copy of the same spec file. Fixed here:

https://github.com/pulp/pulp/pull/1482

+ This comment was cloned from Bugzilla #1174283 comment 5 +

#6 Updated by rbarlow almost 6 years ago

I don't think it is necessary for the Pulp package to also require python-requests >= 2.4, unless Pulp is actually using those features. AIUI, only nectar is using the newer features, so it was correct for Pulp to continue to require >= 2.2. That is, unless someone is aware of something Pulp is doing with python-requests that really does need 2.4. I know of no such usage.

+ This comment was cloned from Bugzilla #1174283 comment 6 +

#7 Updated by amacdona@redhat.com almost 6 years ago

Randy and I talked about this, it is appropriate to change this spec file to match that of the nectar repo.

+ This comment was cloned from Bugzilla #1174283 comment 7 +

#8 Updated by rbarlow almost 6 years ago

My comment was due to a mistake in my interpretation of the details. Carry on!

+ This comment was cloned from Bugzilla #1174283 comment 8 +

#9 Updated by cduryee almost 6 years ago

This was merged to 2.6-dev (2.6.1) , not 2.6-testing (2.6.0).

If you'd like it in 2.6.0, please open a new PR against 2.6-testing and set the bug's target release to 2.6.0.

+ This comment was cloned from Bugzilla #1174283 comment 9 +

#10 Updated by cduryee almost 6 years ago

pulp 2.6.0 beta 5

+ This comment was cloned from Bugzilla #1174283 comment 10 +

#11 Updated by igulina@redhat.com almost 6 years ago

Do I miss something or it failed QA again?

rpm -qa pulp-server

pulp-server-2.6.0-0.5.beta.el6.noarch

rpm -qR python-nectar | grep python-requests

python-requests >= 2.2.1

+ This comment was cloned from Bugzilla #1174283 comment 11 +

#12 Updated by amacdona@redhat.com almost 6 years ago

The code appears to be correct, but the build date for the nectar dep does not. Cracking open the rpm:

Build Date : Thu 21 Aug 2014 02:28:03 PM EDT

Chris, I think that the deps were not rebuilt in this build?

+ This comment was cloned from Bugzilla #1174283 comment 12 +

#13 Updated by cduryee almost 6 years ago

Try now:)

python-nectar 1.3.1-2 should fix this. The fix was in the src tree before but the newer nectar was not tagged.

+ This comment was cloned from Bugzilla #1174283 comment 13 +

#14 Updated by igulina@redhat.com almost 6 years ago

rpm -qa pulp-server

pulp-server-2.6.0-0.5.beta.el6.noarch

rpm -qa python-nectar

python-nectar-1.3.1-2.el6.noarch

rpm -qR python-nectar | grep python-requests

python-requests >= 2.4.3

+ This comment was cloned from Bugzilla #1174283 comment 14 +

#15 Updated by bmbouter almost 6 years ago

  • Severity changed from High to 3. High

#16 Updated by bmbouter almost 6 years ago

  • Tags deleted (Reopened)

#17 Updated by rbarlow over 5 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#19 Updated by bmbouter almost 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF