Project

Profile

Help

Issue #629

closed

Nodes does not use checksum_type when generating a publishing path

Added by rbarlow almost 8 years ago. Updated over 3 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
Nodes uses a checksum to make the publishing path for units, but the path does not also include the checksum type. This was the source of #1165355[0], though there was another way to fix that particular bug that had additional benefits that fixing this bug would not have. We should still add the checksum type to the publishing path of Nodes for correctness.

Version-Release number of selected component (if applicable):
2.4.3-1

How reproducible:
Every time

Steps to Reproduce:
1. Publish a nodes repository, perhaps one that has the "bear" RPM.
2. Look at the path to the published bear RPM.

Actual results:
/var/lib/pulp/nodes/published/https/repos/confused-bear/content/rpm/bear/4.1/1/noarch/7cc8894d84696bfac328a0f7104daec7cbb0f5c4/bear-4.1-1.noarch.rpm

Expected results:
/var/lib/pulp/nodes/published/https/repos/confused-bear/content/rpm/bear/4.1/1/noarch/sha1-7cc8894d84696bfac328a0f7104daec7cbb0f5c4/bear-4.1-1.noarch.rpm, or similar (note the addition of checksum type).

Additional info:
[0] https://bugzilla.redhat.com/show_bug.cgi?id=1165355

+ This bug was cloned from Bugzilla Bug #1168029 +

Actions #1

Updated by bmbouter almost 8 years ago

It doesn't have to be that we add the checksum type to the path. The best thing to use would be the UUID of the database unit.

+ This comment was cloned from Bugzilla #1168029 comment 1 +

Actions #2

Updated by bmbouter over 7 years ago

  • Severity changed from Medium to 2. Medium
Actions #3

Updated by amacdona@redhat.com over 6 years ago

  • Status changed from NEW to CLOSED - WONTFIX

Closed because Pulp 3.0 will be dropping nodes support.

Actions #4

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF