Project

Profile

Help

Issue #617

pulp-consumer rpm repo unbind non-existent repo fails with unexpected error

Added by ipanova@redhat.com almost 7 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.5
Platform Release:
2.6.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

  1. pulp-consumer -u admin -p admin rpm unbind --repo-id invalid-repo
    An unexpected error has occurred. More information can be found in the client
    log file ~/.pulp/consumer.log.
  1. tail -15 ~/.pulp/consumer.log
    return self.method(*arg_list, **clean_kwargs)
    File "/usr/lib/python2.7/site-packages/pulp_rpm/extensions/consumer/pulp_cli.py", line 101, in unbind
    bind_id = e.extra_data['resources']['bind_id']
    KeyError: 'bind_id'
    2014-11-14 14:20:30,304 - ERROR - Client-side exception occurred
    Traceback (most recent call last):
    File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 478, in run
    exit_code = Cli.run(self, args)
    File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 974, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
    File "/usr/lib/python2.7/site-packages/pulp/client/extensions/extensions.py", line 224, in execute
    return self.method(*arg_list, **clean_kwargs)
    File "/usr/lib/python2.7/site-packages/pulp_rpm/extensions/consumer/pulp_cli.py", line 101, in unbind
    bind_id = e.extra_data['resources']['bind_id']
    KeyError: 'bind_id'

Meanwhile:

  1. pulp-consumer -u admin -p admin puppet unbind --repo-id invalid-repo
    The following resource(s) could not be found:
    invalid-repo (repo_id)
    puppet_distributor (distributor_id)

Version-Release number of selected component (if applicable):
2.5.0-0.18.rc

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1164276 +

History

#1 Updated by ipanova@redhat.com over 6 years ago

  • Status changed from ASSIGNED to POST
  • Platform Release set to 2.6.1

#2 Updated by ipanova@redhat.com over 6 years ago

  • Status changed from POST to MODIFIED

#3 Updated by bmbouter over 6 years ago

  • Severity changed from Medium to 2. Medium

#4 Updated by bcourt over 6 years ago

  • Status changed from MODIFIED to 5

#5 Updated by igulina@redhat.com over 6 years ago

  • Status changed from 5 to 6

reproduced on rpm -qa pulp-server

pulp-server-2.6.0-0.7.beta.el6.noarch

pulp-consumer -u admin -p admin rpm unbind --repo-id invalid-repo

An unexpected error has occurred. More information can be found in the client
log file ~/.pulp/consumer.log.

verified on rpm -qa pulp-server
pulp-server-2.6.1-0.2.beta.el6.noarch

pulp-consumer -u admin -p admin rpm unbind --repo-id invalid-repo

Repository [invalid-repo] does not exist on the server

/var/log/messages:
Mar 27 08:27:24 ip-XXX pulp: pulp.server.webservices.middleware.exception:INFO: Missing resource(s): repo_id=invalid-repo, distributor_id=yum_distributor

tail -15 ~/.pulp/consumer.log

2015-01-12 03:29:36,870 - ERROR - Permission denied: user consumer-admin cannot perform CREATE.
2015-01-12 03:30:09,912 - ERROR - Permission denied: user consumer-admin cannot perform CREATE.
2015-01-12 03:34:02,352 - ERROR - Permission denied: user consumer-admin cannot perform CREATE.
2015-01-12 10:54:47,400 - ERROR - Authentication with username amdin failed: invalid username or password
2015-01-13 07:43:54,882 - ERROR - Authentication with username None failed: invalid SSL certificate.
2015-03-27 08:25:31,598 - ERROR - Exception occurred:
href: /pulp/api/v2/consumers/gena.be/bindings/invalid-repo/puppet_distributor/
method: DELETE
status: 404
error: Missing resource(s): repo_id=invalid-repo, distributor_id=puppet_distributor
traceback: None
data: {u'error': {u'code': u'PLP0009', u'data': {u'resources': {u'repo_id': u'invalid-repo', u'distributor_id': u'puppet_distributor'}}, u'description': u'Missing resource(s): repo_id=invalid-repo, distributor_id=puppet_distributor', u'sub_errors': []}, u'resources': {u'repo_id': u'invalid-repo', u'distributor_id': u'puppet_distributor'}}

#6 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF