Project

Profile

Help

Issue #588

closed

Documentation says no No admin.conf.rpmnew file will be generated for 2.3 -> 2.4 but it does

Added by pthomas@redhat.com almost 8 years ago. Updated almost 4 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.5
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Pulp 2
Sprint:
Quarter:

Description

Document URL:
https://pulp-user-guide.readthedocs.org/en/latest/release-notes/2.4.x.html#upgrade-instructions-for-2-3-x-2-4-0

Section Number and Name:

Describe the issue:

The upgrade doc says No admin.conf.rpmnew file will be generated for 2.3 -> 2.4. But seems like it does when I upgraded from 2.3 -> 2.5

Suggestions for improvement:

Additional information:

+ This bug was cloned from Bugzilla Bug #1156037 +

Actions #1

Updated by pthomas@redhat.com almost 8 years ago

[root@cloud-qe-17 ~]# ls l /etc/pulp/admin/
total 12
-rw-r--r-
. 1 root root 1201 Oct 22 10:28 admin.conf
rw-r--r-. 1 root root 2574 Oct 22 09:46 admin.conf.rpmnew
drwxr-xr-x. 2 root root 4096 Oct 23 08:45 conf.d
[root@cloud-qe-17 ~]#

[root@cloud-qe-17 ~]# yum groupupdate pulp-consumer-qpid
Loaded plugins: product-id, pulp-profile-update, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Group Process
Resolving Dependencies
--> Running transaction check
---> Package pulp-agent.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-agent.noarch 0:2.5.0-0.11.beta.el6 will be an update
--> Processing Dependency: python-pulp-bindings = 2.5.0 for package: pulp-agent-2.5.0-0.11.beta.el6.noarch
--> Processing Dependency: python-pulp-agent-lib = 2.5.0 for package: pulp-agent-2.5.0-0.11.beta.el6.noarch
--> Processing Dependency: python-gofer >= 1.3.0 for package: pulp-agent-2.5.0-0.11.beta.el6.noarch
--> Processing Dependency: gofer >= 1.3.0 for package: pulp-agent-2.5.0-0.11.beta.el6.noarch
---> Package pulp-consumer-client.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-consumer-client.noarch 0:2.5.0-0.11.beta.el6 will be an update
--> Processing Dependency: python-pulp-common = 2.5.0 for package: pulp-consumer-client-2.5.0-0.11.beta.el6.noarch
--> Processing Dependency: python-pulp-client-lib = 2.5.0 for package: pulp-consumer-client-2.5.0-0.11.beta.el6.noarch
---> Package pulp-puppet-consumer-extensions.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-puppet-consumer-extensions.noarch 0:2.5.0-0.11.beta.el6 will be an update
--> Processing Dependency: python-pulp-puppet-common = 2.5.0 for package: pulp-puppet-consumer-extensions-2.5.0-0.11.beta.el6.noarch
---> Package pulp-puppet-handlers.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-puppet-handlers.noarch 0:2.5.0-0.11.beta.el6 will be an update
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers-2.5.0-0.11.beta.el6.noarch
---> Package pulp-rpm-consumer-extensions.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-rpm-consumer-extensions.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package pulp-rpm-handlers.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-rpm-handlers.noarch 0:2.5.0-0.11.beta.el6 will be an update
--> Processing Dependency: python-pulp-rpm-common = 2.5.0 for package: pulp-rpm-handlers-2.5.0-0.11.beta.el6.noarch
---> Package pulp-rpm-yumplugins.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-rpm-yumplugins.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package python-gofer-qpid.noarch 0:1.3.1-1.el6 will be installed
--> Running transaction check
---> Package gofer.noarch 0:0.77.1-1.el6 will be updated
---> Package gofer.noarch 0:1.3.1-1.el6 will be an update
---> Package puppet.noarch 0:2.7.25-2.el6 will be installed
--> Processing Dependency: facter < 1:2.0 for package: puppet-2.7.25-2.el6.noarch
--> Processing Dependency: ruby(abi) >= 1.8 for package: puppet-2.7.25-2.el6.noarch
--> Processing Dependency: ruby >= 1.8.5 for package: puppet-2.7.25-2.el6.noarch
--> Processing Dependency: facter >= 1.5 for package: puppet-2.7.25-2.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-2.7.25-2.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-2.7.25-2.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-2.7.25-2.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-2.7.25-2.el6.noarch
---> Package python-gofer.noarch 0:0.77.1-1.el6 will be updated
---> Package python-gofer.noarch 0:1.3.1-1.el6 will be an update
---> Package python-pulp-agent-lib.noarch 0:2.3.1-1.el6 will be updated
---> Package python-pulp-agent-lib.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package python-pulp-bindings.noarch 0:2.3.1-1.el6 will be updated
--> Processing Dependency: python-pulp-bindings = 2.3.1 for package: pulp-admin-client-2.3.1-1.el6.noarch
---> Package python-pulp-bindings.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package python-pulp-client-lib.noarch 0:2.3.1-1.el6 will be updated
---> Package python-pulp-client-lib.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package python-pulp-common.noarch 0:2.3.1-1.el6 will be updated
--> Processing Dependency: python-pulp-common = 2.3.1 for package: pulp-puppet-admin-extensions-2.3.1-1.el6.noarch
--> Processing Dependency: python-pulp-common = 2.3.1 for package: pulp-server-2.3.1-1.el6.noarch
--> Processing Dependency: python-pulp-common = 2.3.1 for package: pulp-puppet-plugins-2.3.1-1.el6.noarch
---> Package python-pulp-common.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package python-pulp-puppet-common.noarch 0:2.3.1-1.el6 will be updated
---> Package python-pulp-puppet-common.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package python-pulp-rpm-common.noarch 0:2.3.1-1.el6 will be updated
--> Processing Dependency: python-pulp-rpm-common = 2.3.1 for package: pulp-rpm-plugins-2.3.1-1.el6.noarch
---> Package python-pulp-rpm-common.noarch 0:2.5.0-0.11.beta.el6 will be obsoleting
---> Package python-pulp-rpm-extension.noarch 0:2.3.1-1.el6 will be obsoleted
--> Processing Dependency: python-pulp-rpm-extension = 2.3.1 for package: pulp-rpm-admin-extensions-2.3.1-1.el6.noarch
--> Running transaction check
---> Package facter.x86_64 0:1.6.18-3.el6 will be installed
---> Package libselinux-ruby.x86_64 0:2.0.94-5.8.el6 will be installed
---> Package pulp-admin-client.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-admin-client.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package pulp-puppet-admin-extensions.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-puppet-admin-extensions.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package pulp-puppet-plugins.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-puppet-plugins.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package pulp-rpm-admin-extensions.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-rpm-admin-extensions.noarch 0:2.5.0-0.11.beta.el6 will be an update
---> Package pulp-rpm-plugins.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-rpm-plugins.noarch 0:2.5.0-0.11.beta.el6 will be an update
--> Processing Dependency: python-nectar >= 1.2.1 for package: pulp-rpm-plugins-2.5.0-0.11.beta.el6.noarch
---> Package pulp-server.noarch 0:2.3.1-1.el6 will be updated
---> Package pulp-server.noarch 0:2.5.0-0.11.beta.el6 will be an update
--> Processing Dependency: python-celery < 3.2.0 for package: pulp-server-2.5.0-0.11.beta.el6.noarch
--> Processing Dependency: python-celery >= 3.1.0 for package: pulp-server-2.5.0-0.11.beta.el6.noarch
---> Package ruby.x86_64 0:1.8.7.374-2.el6 will be installed
---> Package ruby-augeas.x86_64 0:0.4.1-1.el6 will be installed
--> Processing Dependency: augeas-libs >= 0.8.0 for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
---> Package ruby-libs.x86_64 0:1.8.7.374-2.el6 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.374-2.el6.x86_64
---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed
--> Running transaction check
---> Package augeas-libs.x86_64 0:1.0.0-7.el6 will be installed
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package python-celery.noarch 0:3.1.11-1.el6 will be installed
--> Processing Dependency: python-kombu >= 3.0.15 for package: python-celery-3.1.11-1.el6.noarch
--> Processing Dependency: python-billiard >= 3.3.0.17 for package: python-celery-3.1.11-1.el6.noarch
--> Processing Dependency: pytz for package: python-celery-3.1.11-1.el6.noarch
--> Processing Dependency: python-importlib for package: python-celery-3.1.11-1.el6.noarch
--> Processing Dependency: python-anyjson for package: python-celery-3.1.11-1.el6.noarch
--> Processing Dependency: python-amqp for package: python-celery-3.1.11-1.el6.noarch
--> Processing Dependency: pyparsing for package: python-celery-3.1.11-1.el6.noarch
---> Package python-nectar.noarch 0:1.1.6-1.el6 will be updated
---> Package python-nectar.noarch 0:1.3.1-1.el6 will be an update
--> Processing Dependency: python-requests >= 2.2.1 for package: python-nectar-1.3.1-1.el6.noarch
--> Running transaction check
---> Package pyparsing.noarch 0:1.5.6-1.el6 will be installed
---> Package python-amqp.noarch 0:1.4.5-1.el6 will be installed
---> Package python-anyjson.noarch 0:0.3.3-4.el6 will be installed
---> Package python-billiard.x86_64 1:3.3.0.17-1.el6 will be installed
---> Package python-importlib.noarch 0:1.0.2-1.el6 will be installed
---> Package python-kombu.noarch 1:3.0.15-12.pulp.el6 will be installed
--> Processing Dependency: python-ordereddict for package: 1:python-kombu-3.0.15-12.pulp.el6.noarch
---> Package python-requests.noarch 0:2.0.0-1.el6 will be updated
---> Package python-requests.noarch 0:2.2.1-1.el6 will be an update
---> Package pytz.noarch 0:2010h-2.el6 will be installed
--> Running transaction check
---> Package python-ordereddict.noarch 0:1.1-2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
python-gofer-qpid noarch 1.3.1-1.el6 pulp-2.4-beta 49 k
python-pulp-rpm-common noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 59 k
replacing python-pulp-rpm-extension.noarch 2.3.1-1.el6
Updating:
pulp-agent noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 62 k
pulp-consumer-client noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 72 k
pulp-puppet-consumer-extensions
noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 23 k
pulp-puppet-handlers noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 28 k
pulp-rpm-consumer-extensions noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 42 k
pulp-rpm-handlers noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 66 k
pulp-rpm-yumplugins noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 39 k
Installing for dependencies:
augeas-libs x86_64 1.0.0-7.el6 beaker-Server 314 k
compat-readline5 x86_64 5.2-17.1.el6 beaker-Server 129 k
facter x86_64 1.6.18-3.el6 epel 62 k
libselinux-ruby x86_64 2.0.94-5.8.el6 beaker-Server 100 k
puppet noarch 2.7.25-2.el6 epel 1.1 M
pyparsing noarch 1.5.6-1.el6 epel 94 k
python-amqp noarch 1.4.5-1.el6 pulp-2.4-beta 82 k
python-anyjson noarch 0.3.3-4.el6 pulp-2.4-beta 12 k
python-billiard x86_64 1:3.3.0.17-1.el6 pulp-2.4-beta 178 k
python-celery noarch 3.1.11-1.el6 pulp-2.4-beta 1.9 M
python-importlib noarch 1.0.2-1.el6 epel 6.3 k
python-kombu noarch 1:3.0.15-12.pulp.el6 pulp-2.4-beta 504 k
python-ordereddict noarch 1.1-2.el6 epel 7.6 k
pytz noarch 2010h-2.el6 beaker-Server 35 k
ruby x86_64 1.8.7.374-2.el6 beaker-Server 538 k
ruby-augeas x86_64 0.4.1-1.el6 epel 21 k
ruby-libs x86_64 1.8.7.374-2.el6 beaker-Server 1.7 M
ruby-shadow x86_64 1.4.1-13.el6 epel 11 k
Updating for dependencies:
gofer noarch 1.3.1-1.el6 pulp-2.4-beta 72 k
pulp-admin-client noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 89 k
pulp-puppet-admin-extensions noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 49 k
pulp-puppet-plugins noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 87 k
pulp-rpm-admin-extensions noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 137 k
pulp-rpm-plugins noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 287 k
pulp-server noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 698 k
python-gofer noarch 1.3.1-1.el6 pulp-2.4-beta 119 k
python-nectar noarch 1.3.1-1.el6 pulp-2.4-beta 41 k
python-pulp-agent-lib noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 74 k
python-pulp-bindings noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 99 k
python-pulp-client-lib noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 188 k
python-pulp-common noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 111 k
python-pulp-puppet-common noarch 2.5.0-0.11.beta.el6 pulp-2.4-beta 34 k
python-requests noarch 2.2.1-1.el6 pulp-2.4-beta 537 k

Transaction Summary
================================================================================
Install 20 Package(s)
Upgrade 22 Package(s)

Total download size: 9.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/42): augeas-libs-1.0.0-7.el6.x86_64.rpm | 314 kB 00:00
(2/42): compat-readline5-5.2-17.1.el6.x86_64.rpm | 129 kB 00:00
(3/42): facter-1.6.18-3.el6.x86_64.rpm | 62 kB 00:00
(4/42): gofer-1.3.1-1.el6.noarch.rpm | 72 kB 00:00
(5/42): libselinux-ruby-2.0.94-5.8.el6.x86_64.rpm | 100 kB 00:00
(6/42): pulp-admin-client-2.5.0-0.11.beta.el6.noarch.rpm | 89 kB 00:00
(7/42): pulp-agent-2.5.0-0.11.beta.el6.noarch.rpm | 62 kB 00:00
(8/42): pulp-consumer-client-2.5.0-0.11.beta.el6.noarch. | 72 kB 00:00
(9/42): pulp-puppet-admin-extensions-2.5.0-0.11.beta.el6 | 49 kB 00:00
(10/42): pulp-puppet-consumer-extensions-2.5.0-0.11.beta | 23 kB 00:00
(11/42): pulp-puppet-handlers-2.5.0-0.11.beta.el6.noarch | 28 kB 00:00
(12/42): pulp-puppet-plugins-2.5.0-0.11.beta.el6.noarch. | 87 kB 00:00
(13/42): pulp-rpm-admin-extensions-2.5.0-0.11.beta.el6.n | 137 kB 00:00
(14/42): pulp-rpm-consumer-extensions-2.5.0-0.11.beta.el | 42 kB 00:00
(15/42): pulp-rpm-handlers-2.5.0-0.11.beta.el6.noarch.rp | 66 kB 00:00
(16/42): pulp-rpm-plugins-2.5.0-0.11.beta.el6.noarch.rpm | 287 kB 00:00
(17/42): pulp-rpm-yumplugins-2.5.0-0.11.beta.el6.noarch. | 39 kB 00:00
(18/42): pulp-server-2.5.0-0.11.beta.el6.noarch.rpm | 698 kB 00:00
(19/42): puppet-2.7.25-2.el6.noarch.rpm | 1.1 MB 00:00
(20/42): pyparsing-1.5.6-1.el6.noarch.rpm | 94 kB 00:00
(21/42): python-amqp-1.4.5-1.el6.noarch.rpm | 82 kB 00:00
(22/42): python-anyjson-0.3.3-4.el6.noarch.rpm | 12 kB 00:00
(23/42): python-billiard-3.3.0.17-1.el6.x86_64.rpm | 178 kB 00:00
(24/42): python-celery-3.1.11-1.el6.noarch.rpm | 1.9 MB 00:00
(25/42): python-gofer-1.3.1-1.el6.noarch.rpm | 119 kB 00:00
(26/42): python-gofer-qpid-1.3.1-1.el6.noarch.rpm | 49 kB 00:00
(27/42): python-importlib-1.0.2-1.el6.noarch.rpm | 6.3 kB 00:00
(28/42): python-kombu-3.0.15-12.pulp.el6.noarch.rpm | 504 kB 00:00
(29/42): python-nectar-1.3.1-1.el6.noarch.rpm | 41 kB 00:00
(30/42): python-ordereddict-1.1-2.el6.noarch.rpm | 7.6 kB 00:00
(31/42): python-pulp-agent-lib-2.5.0-0.11.beta.el6.noarc | 74 kB 00:00
(32/42): python-pulp-bindings-2.5.0-0.11.beta.el6.noarch | 99 kB 00:00
(33/42): python-pulp-client-lib-2.5.0-0.11.beta.el6.noar | 188 kB 00:00
(34/42): python-pulp-common-2.5.0-0.11.beta.el6.noarch.r | 111 kB 00:00
(35/42): python-pulp-puppet-common-2.5.0-0.11.beta.el6.n | 34 kB 00:00
(36/42): python-pulp-rpm-common-2.5.0-0.11.beta.el6.noar | 59 kB 00:00
(37/42): python-requests-2.2.1-1.el6.noarch.rpm | 537 kB 00:00
(38/42): pytz-2010h-2.el6.noarch.rpm | 35 kB 00:00
(39/42): ruby-1.8.7.374-2.el6.x86_64.rpm | 538 kB 00:00
(40/42): ruby-augeas-0.4.1-1.el6.x86_64.rpm | 21 kB 00:00
(41/42): ruby-libs-1.8.7.374-2.el6.x86_64.rpm | 1.7 MB 00:00
(42/42): ruby-shadow-1.4.1-13.el6.x86_64.rpm | 11 kB 00:00
--------------------------------------------------------------------------------
Total 636 kB/s | 9.6 MB 00:15
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : python-pulp-common-2.5.0-0.11.beta.el6.noarch 1/66
Updating : python-pulp-bindings-2.5.0-0.11.beta.el6.noarch 2/66
Updating : python-gofer-1.3.1-1.el6.noarch 3/66
Updating : python-pulp-puppet-common-2.5.0-0.11.beta.el6.noarch 4/66
Updating : python-pulp-agent-lib-2.5.0-0.11.beta.el6.noarch 5/66
Installing : python-pulp-rpm-common-2.5.0-0.11.beta.el6.noarch 6/66
Installing : python-gofer-qpid-1.3.1-1.el6.noarch 7/66
Updating : python-pulp-client-lib-2.5.0-0.11.beta.el6.noarch 8/66
Updating : pulp-consumer-client-2.5.0-0.11.beta.el6.noarch 9/66
warning: /etc/pulp/consumer/consumer.conf created as /etc/pulp/consumer/consumer.conf.rpmnew
Updating : pulp-admin-client-2.5.0-0.11.beta.el6.noarch 10/66
warning: /etc/pulp/admin/admin.conf created as /etc/pulp/admin/admin.conf.rpmnew
Installing : python-amqp-1.4.5-1.el6.noarch 11/66
Installing : python-anyjson-0.3.3-4.el6.noarch 12/66
Updating : gofer-1.3.1-1.el6.noarch 13/66
Updating : python-requests-2.2.1-1.el6.noarch

+ This comment was cloned from Bugzilla #1156037 comment 1 +

Actions #2

Updated by bmbouter almost 8 years ago

  • Category deleted (1)
  • Tags Documentation added

Documentation is now a Tag not a Category.

Actions #3

Updated by bmbouter almost 8 years ago

  • Severity changed from Low to 1. Low
Actions #4

Updated by bmbouter almost 4 years ago

  • Status changed from NEW to CLOSED - WONTFIX
Actions #5

Updated by bmbouter almost 4 years ago

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

Actions #6

Updated by bmbouter almost 4 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF