Project

Profile

Help

Issue #580

relative-url is not required to be unique

Added by justin.garrison@disneyanimation.com over 6 years ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.1
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem: different repos can have the same relative-url

Version-Release number of selected component (if applicable): 2.4.1

How reproducible: Every time

Steps to Reproduce:
1. Create repo with --relative-url
2. create second repo with same relative-url
3. publish both repos

Actual results:
repo that is published last is the one published at the relative url

Expected results:
Checking would prevent setting a relative url that already exists

Additional info:

+ This bug was cloned from Bugzilla Bug #1153795 +

History

#1 Updated by amacdona@redhat.com over 6 years ago

Related to this one:

https://bugzilla.redhat.com/show_bug.cgi?id=1079511

+ This comment was cloned from Bugzilla #1153795 comment 1 +

#2 Updated by amacdona@redhat.com over 6 years ago

https://github.com/pulp/pulp/pull/1297

This was solved by the PR for BZ1079511, but is not marked as a duplicate because this was a different problem caused by the same code.

+ This comment was cloned from Bugzilla #1153795 comment 2 +

#3 Updated by cduryee over 6 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1153795 comment 3 +

#4 Updated by igulina@redhat.com over 6 years ago

rpm -qa pulp-server

pulp-server-2.6.0-0.2.beta.el6.noarch

pulp-admin rpm repo create --repo-id repo1 --relative-url repo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/horse-0.22-2.noarch.rpm

Successfully created repository [repo1]

pulp-admin rpm repo create --repo-id repo2 --relative-url repo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/zebra-0.1-2.noarch.rpm

The server indicated one or more values were incorrect. The server provided the
following error message:

Relative URL [repo] for repository [repo2] conflicts with existing relative
URL [repo] for repository [repo1]

More information can be found in the client log file ~/.pulp/admin.log.

+ This comment was cloned from Bugzilla #1153795 comment 4 +

#5 Updated by bmbouter over 6 years ago

  • Severity changed from Medium to 2. Medium

#6 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF