Project

Profile

Help

Issue #5566

Travis CI for ansible-pulp fails to configure firewalld on CentOS 7 and Fedora

Added by mdepaulo@redhat.com 9 months ago. Updated about 2 months ago.

Status:
NEW
Priority:
Normal
Assignee:
-
Category:
Installer
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
CI/CD
Sprint:

Description

1st of all, this issue isn't severe because:
1. We are still testing the firewall codepath (in ansible-pulp) on Debian 10 successfully.
2. It seems to only affect containers (ansible molecule CI testing uses containers with systemd running in them, but pulp-operator managed container do not use their own firewalls or systemd.)

The issue is that we had to disable the firewall (by setting the ansible-pulp variable) in the CI for C7 and F30 due to:
1. CentOS 7.7 specifically seemed to break it. Although molecule was doing service disable hacks under /usr (now removed from the molecule Dockerfile) to CentOS 7.6, and then yum updating to 7.7, which blew them away.
2. With privileged mode removed from the ansible molecule, it no longer works on CentOS 7.7 or Fedora 30. Only Debian 10.

This means our CI testing is not quite as thorough as it should be.

History

#1 Updated by fao89 9 months ago

  • Triaged changed from No to Yes

#2 Updated by fao89 7 months ago

  • Tags CI/CD added

#3 Updated by bmbouter about 2 months ago

  • Category set to Installer
  • Tags deleted (Pulp 3 installer)

Please register to edit this issue

Also available in: Atom PDF