Project

Profile

Help

Issue #547

Pulp should not allow users to upload srpms as rpms

Added by rbarlow almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.4.0
Platform Release:
2.6.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
We've had a bug[0] filed before that happened as a result of a user uploading srpms as rpms. If possible, Pulp should prevent this.

Version-Release number of selected component (if applicable):
2.4.0-1

How reproducible:
Every time

Steps to Reproduce:
1. Use pulp-admin to upload an srpm as an rpm

Actual results:
It will succeed.

Expected results:
It should fail.

Additional info:
[0] https://bugzilla.redhat.com/show_bug.cgi?id=1016612

+ This bug was cloned from Bugzilla Bug #1146703 +

History

#2 Updated by bmbouter almost 7 years ago

  • Severity changed from High to 3. High

#3 Updated by bcourt almost 7 years ago

  • Status changed from MODIFIED to 5

#4 Updated by pthomas@redhat.com almost 7 years ago

  • Status changed from 5 to 6

verified
[root@qe-blade-10 ~]# rpm -qa pulp-server
pulp-server-2.6.1-0.2.beta.el6.noarch
[root@qe-blade-10 ~]#

[root@qe-blade-10 ~]# 
[root@qe-blade-10 ~]# pulp-admin rpm repo uploads  rpm --repo-id srpm -f test-srpm01-1.0-1.src.rpm -v
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: test-srpm01-1.0-1.src.rpm
... completed

Files to be uploaded:
  test-srpm01-1.0-1.src.rpm

Creating upload requests on the server...
[==================================================] 100%
Initializing: test-srpm01-1.0-1.src.rpm
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: test-srpm01-1.0-1.src.rpm
[==================================================] 100%
1607/1607 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Failed

Error uploading an RPM.  The specified file is a source rpm

Deleting the upload request...
... completed

<\pre>

#6 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#8 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF