Project

Profile

Help

Issue #5387

closed

python module breaks API docs browser

Added by jaymzh almost 3 years ago. Updated about 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version - Python:
Platform Release:
Target Release - Python:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

After installing pulp-python when I browse to :24817/pulp/api/v3/docs/ I get:

Error downloading http://10.224.41.73:24817/pulp/api/v3/docs/?format=openapi HTTP ERROR 500

Stack trace

s/<@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:55:6276
e/</<@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:100:35503
a@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:67:126299
R/<@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:67:126444
c@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:67:129838

s/<@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:55:6276
e/</<@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:100:35083
a@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:67:126299
R/<@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:67:126444
c@http://10.224.41.73:24817/static/drf-yasg/redoc/redoc.min.js:67:129838

ReDoc Version: 2.0.0-rc.8-1
Commit: 4d8cba1

Related issues

Is duplicate of Python Support - Issue #5452: OpenAPI schema endpoint returns 500 error when pulp_python is installedMODIFIEDdkliban@redhat.comActions
Actions #1

Updated by dalley about 2 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #2

Updated by dalley about 2 years ago

  • Is duplicate of Issue #5452: OpenAPI schema endpoint returns 500 error when pulp_python is installed added

Also available in: Atom PDF