Project

Profile

Help

Issue #5360

Debian Buster updates sync results in an empty Architectures field in the Release file

Added by signed8bit about 1 year ago. Updated about 1 month ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When syncing the Debian Buster updates repo, the generated Release file contains an empty "Architectures" field instead of containing the configured architectures.

Create a repo with the following parameters.

Feed: http://deb.debian.org/debian
Releases: buster-updates
Architectures: amd64
Components: main,contrib,non-free

After syncing, note that the generated Release file will contain and empty "Architectures" field.

Example:

Label: upstream_debian-buster-updates_2019-08-27-135800
Suite: stable-updates
Codename: buster-updates
Date: Tue, 27 Aug 2019 13:58:47 +0000
Architectures:
Components: non-free contrib main
...

Observed with Pulp 2.20.0 (Debian support: 1.10.0).


Related issues

Is duplicate of Debian Support - Issue #4094: Architecture is not created if there are no architecture specific packagesNEW<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ggainey about 1 year ago

  • Tags Pulp 2 added

Notes from a quick (successful) attempt to reproduce, run against up2date 2-master:

# pulp-admin deb repo create --repo-id buster --releases buster-updates --architectures amd64 --components  main,contrib,non-free --feed http://deb.debian.org/debian
# pulp-admin deb repo sync run --repo-id buster
# head /var/lib/pulp/published/deb/master/deb_distributor/buster/1566918812.18/dists/buster-updates/Release
Label: buster
Suite: stable-updates
Codename: buster-updates
Date: Tue, 27 Aug 2019 15:13:32 +0000
Architectures:
Components: non-free contrib main
MD5sum:

#2 Updated by quba42 about 1 year ago

This is a duplicate of https://pulp.plan.io/issues/4094

Since buster-updates currently contains no packages, it also contains no architecture specific packages.
Since there are no architecture specific packages pulp_deb does not create any architectures, and does not add them to the Release file.

#3 Updated by quba42 about 1 year ago

  • Is duplicate of Issue #4094: Architecture is not created if there are no architecture specific packages added

#4 Updated by signed8bit about 1 year ago

It appears that it currently contains two "all" packages, e.g. libdatetime-timezone-perl_1:2.23-1+2019b_all.deb and tzdata_2019b-0+deb10u1_all.deb. This makes sense then given the description in https://pulp.plan.io/issues/4094. Thanks for the link to that issue.

#5 Updated by quba42 about 1 month ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF