Project

Profile

Help

Issue #532

using results in --host-ca fails with Configuration key [https_ca] is not supported

Added by pthomas@redhat.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.1
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
Repo create using --host-ca fails with Configuration key [https_ca] is not supported

Version-Release number of selected component (if applicable):
[root@qe-blade-13 ~]# rpm -qa pulp-server
pulp-server-2.4.1-0.8.beta.el6.noarch
[root@qe-blade-13 ~]#

How reproducible:

Steps to Reproduce:
1. Create a repo with --host-ca value
2.
3.

Actual results:
[root@qe-blade-13 ~]# pulp-admin rpm repo create --repo-id=myRepo --host-ca /root/client.key --auth-ca /root/caPulp.crt --auth-cert /root/client.crt
The server indicated one or more values were incorrect. The server provided the
following error message:

Configuration key [https_ca] is not supported

More information can be found in the client log file ~/.pulp/admin.log.

Expected results:

Additional info:

Sep 16 12:47:51 qe-blade-13 pulp: pulp.plugins.pulp_rpm.plugins.distributors.yum.configuration:ERROR: Configuration key [https_ca] is not supported
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: Exception adding distributor to repo [pulp2]; the repo will be deleted
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: Traceback (most recent call last):
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/cud.py", line 186, in create_and_configure_repo
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: distributor_id)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/distributor.py", line 184, in add_distributor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: raise PulpDataException(message)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.managers.repo.cud:ERROR: PulpDataException: Configuration key [https_ca] is not supported
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: Configuration key [https_ca] is not supported
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: Traceback (most recent call last):
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/exception.py", line 44, in call
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return self.app(environ, start_response)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/postponed.py", line 42, in call
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return self.app(environ, start_response)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 279, in wsgi
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: result = self.handle_with_processors()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 29, in _handle_with_processors
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return process(self.processors)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 566, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 581, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: result = handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return self.handle()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 230, in handle
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return self._delegate(fn, self.fvars, args)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 422, in _delegate
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return f()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 430, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: f = lambda: self._delegate_sub_application(pat, what)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 455, in _delegate_sub_application
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return app.handle_with_processors()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 29, in _handle_with_processors
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return process(self.processors)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 566, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 581, in processor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: result = handler()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return p(lambda: process(processors))
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in process
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return self.handle()
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 230, in handle
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return self._delegate(fn, self.fvars, args)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 420, in _delegate
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return handle_class(cls)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/web/application.py", line 396, in handle_class
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: return tocall(*args)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 227, in _auth_decorator
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: value = method(self, *args, **kwargs)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/repositories.py", line 166, in POST
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: repo = repo_manager.create_and_configure_repo(*args, **kwargs)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/cud.py", line 186, in create_and_configure_repo
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: distributor_id)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/managers/repo/distributor.py", line 184, in add_distributor
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware.exception:ERROR: raise PulpDataException(message)
Sep 16 12:47:51 qe-blade-13 pulp: pulp.server.webservices.middleware

+ This bug was cloned from Bugzilla Bug #1142385 +

History

#1 Updated by cduryee over 6 years ago

Need to investigate if option is ok to remove everywhere (cli, api, etc)

+ This comment was cloned from Bugzilla #1142385 comment 1 +

#2 Updated by pthomas@redhat.com over 6 years ago

Looks like this is related to this bz

https://bugzilla.redhat.com/show_bug.cgi?id=1119126

+ This comment was cloned from Bugzilla #1142385 comment 2 +

#3 Updated by bmbouter over 2 years ago

  • Status changed from NEW to CLOSED - WONTFIX
  • Severity set to 2. Medium

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF