Project

Profile

Help

Task #5122

test ansible-pulp PRs using playbooks for pulpcore, pulp_file, and ansible-pulp

Added by dkliban@redhat.com 3 months ago. Updated 28 days ago.

Status:
NEW
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Pulp 3 installer
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

In order to identify changes that require updating pulpcore and pulp_file playbooks used by Travis, the ansible-pulp Travis config should provide builds that run the ansible-pulp changes with the playbooks from ansible-pulp0, pulpcore1, and pulp_file2. When changes are required to the pulpcore or pulp_file Travis playbooks, a Required PR should be specified in the commit message for the ansible-pulp PR.

[0] https://github.com/pulp/ansible-pulp/blob/master/example-use/playbook.yml
[1] https://github.com/pulp/pulpcore/blob/master/.travis/pulpcore_playbook.yml
[2] https://github.com/pulp/pulp_file/blob/master/.travis/playbook.yml

History

#1 Updated by dkliban@redhat.com 3 months ago

  • Description updated (diff)

#2 Updated by bmbouter 3 months ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

+1 This is what we need to do to prevent the breaking changes we experienced last week.

#3 Updated by rchan 3 months ago

  • Sprint set to Sprint 56

#4 Updated by ggainey 3 months ago

  • Tags Pulp 3 installer added

#5 Updated by rchan 2 months ago

  • Sprint changed from Sprint 56 to Sprint 57

#6 Updated by rchan about 2 months ago

  • Sprint changed from Sprint 57 to Sprint 58

#7 Updated by rchan 28 days ago

  • Sprint deleted (Sprint 58)

Please register to edit this issue

Also available in: Atom PDF