Project

Profile

Help

Task #5073

Add pre-commit to plugin_template

Added by daviddavis over 1 year ago. Updated about 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Plugin Template
Sprint:
Quarter:

Description

Pre-commit is a great tool which devs can use to automatically or manually run checks like flake8 before committing code. I think we should consider adding it to plugin_template.

https://pre-commit.com/


Related issues

Related to Pulp - Task #5019: Adopt black and pydocstyleNEW

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Story #6938: As a developer, I have an easy way to check my commit and code locally before pushingPOST

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by daviddavis over 1 year ago

  • Related to Task #5019: Adopt black and pydocstyle added

#2 Updated by amacdona@redhat.com over 1 year ago

  • Tracker changed from Issue to Task
  • % Done set to 0

#3 Updated by daviddavis about 2 months ago

  • Is duplicate of Story #6938: As a developer, I have an easy way to check my commit and code locally before pushing added

#4 Updated by daviddavis about 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF