Project

Profile

Help

Issue #465

Wrong _href in the response body of consumer profile creation

Added by ipanova@redhat.com almost 7 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4 Beta
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
Wrong _href in the response body of consumer profile creation

$ curl -H "Accept: application/json" -X POST -k -u admin:admin -d '{"content_type": "rpm","profile": [{"arch": "i686","epoch": 0,"name": "glib2","release": "2.fc17","vendor": "Fedora Project","version": "2.32.4"},{"arch": "x86_64","epoch": 0,"name": "rpm-libs","release": "8.fc17","vendor": "Fedora Project","version": "4.9.1.8"}]}' 'https://example.com/pulp/api/v2/consumers/c1/profiles/'|python -m json.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   812  100   548  100   264    552    266 --:--:-- --:--:-- --:--:--   552
{
    "_href": "/pulp/api/v2/consumers/c1/profiles/c1/rpm/",
    "_id": {
        "$oid": "53b3fed2783d044f47fd9b3c"
    },
    "_ns": "consumer_unit_profiles",
    "consumer_id": "c1",
    "content_type": "rpm",
    "id": "53b3fed2783d044f47fd9b3c",
    "profile": [
        {
            "arch": "i686",
            "epoch": 0,
            "name": "glib2",
            "release": "2.fc17",
            "vendor": "Fedora Project",
            "version": "2.32.4"
        },
        {
            "arch": "x86_64",
            "epoch": 0,
            "name": "rpm-libs",
            "release": "8.fc17",
            "vendor": "Fedora Project",
            "version": "4.9.1.8"
        }
    ],
    "profile_hash": "9afe3bde4abc67de570b1a043c2057c3c8d5cabdfcf3fd3037bb746e25a4a5fa"
}

$ curl -H "Accept: application/json" -X GET -k -u admin:admin 'https://example.com/pulp/api/v2/consumers/c1/profiles/c1/rpm/'|python -m json.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100     9    0     9    0     0      8      0 --:--:--  0:00:01 --:--:--     8
No JSON object could be decoded

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1115486 +


Related issues

Is duplicate of Pulp - Issue #466: Wrong _href in the response body of consumer profile creationCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ipanova@redhat.com almost 7 years ago

Version-Release number of selected component (if applicable):

2.4.0-0.23.beta

+ This comment was cloned from Bugzilla #1115486 comment 1 +

#2 Updated by ipanova@redhat.com over 6 years ago

  • Parent task set to #466

#3 Updated by ipanova@redhat.com over 6 years ago

  • Status changed from NEW to 7

#4 Updated by bmbouter over 6 years ago

  • Description updated (diff)
  • Status changed from 7 to CLOSED - DUPLICATE
  • Parent task deleted (#466)

#5 Updated by bmbouter over 6 years ago

  • Is duplicate of Issue #466: Wrong _href in the response body of consumer profile creation added

#6 Updated by bmbouter over 2 years ago

  • Severity set to 2. Medium

#7 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#8 Updated by bmbouter over 1 year ago

  • Category deleted (14)

We are removing the 'API' category per open floor discussion June 16, 2020.

Please register to edit this issue

Also available in: Atom PDF