Project

Profile

Help

Issue #462

unable to upload docker tar file when using latest docker package.

Added by cduryee over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version - Docker:
master
Platform Release:
Target Release - Docker:
1.0.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem: When docker-io-1.0.0-3 is installed, I'm unable to upload saved tar files.

  1. docker pull busybox
  2. docker save busybox > busybox.tar
  3. pulp-admin docker repo uploads upload --repo-id=busybox -f busybox.tar

Version-Release number of selected component (if applicable): latest master (hash f3146f5)

How reproducible: every time

Actual results:

Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: Error from the importer while importing uploaded unit to repository [busybox]
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: Traceback (most recent call last):
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: File "/usr/lib/python2.6/site-packages/pulp/server/managers/content/upload.py", line 223, in import_uploaded_unit
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: unit_metadata, file_path, conduit, call_config)
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: File "/usr/lib/python2.6/site-packages/pulp_docker/plugins/importers/importer.py", line 81, in upload_unit
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: metadata = tarutils.get_metadata(file_path)
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: File "/usr/lib/python2.6/site-packages/pulp_docker/common/tarutils.py", line 34, in get_metadata
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: 'size': image_data['Size']
Jun 30 18:20:05 pulp24-clonebase pulp: pulp.server.managers.content.upload:ERROR: KeyError: 'id'

+ This bug was cloned from Bugzilla Bug #1114771 +

History

#1 Updated by mhrivnak over 6 years ago

It looks like docker is now generating metadata with those attribute names capitalized.

+ This comment was cloned from Bugzilla #1114771 comment 1 +

#3 Updated by cduryee over 6 years ago

This has been in POST but looks to be merged. OK to change to MODIFIED?

+ This comment was cloned from Bugzilla #1114771 comment 3 +

#4 Updated by bmbouter over 6 years ago

  • Severity set to 1. Low
  • Version deleted (Master)
  • Version - Docker set to master

#5 Updated by dkliban@redhat.com over 6 years ago

  • Status changed from MODIFIED to 5
  • Target Release - Docker set to 1.0.0

#6 Updated by pthomas@redhat.com over 6 years ago

  • Status changed from 5 to 6

verified

[root@mgmt7 ~]# pulp-admin docker repo create --repo-id=busybox
Repository [busybox] successfully created

[root@mgmt7 ~]# pulp-admin docker repo uploads upload --repo-id=busybox -f busybox.tar
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: busybox.tar
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: busybox.tar
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: busybox.tar
[==================================================] 100%
2660352/2660352 bytes
... completed

Importing into the repository...
This command may be exited via ctrl+c without affecting the request.

[|]
Running...

Task Succeeded

Deleting the upload request...
... completed

[root@mgmt7 ~]# 

<\pre>

#7 Updated by dkliban@redhat.com about 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#9 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF