Project

Profile

Help

Issue #452

pulp-server depends on qpid newer than 0.17

Added by mkovacik@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Low
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4 Beta
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
RHEL6 being a supported target platform for pulp-server deployment, pulp-server package group should require a qpid version that is available on RHEL6.

Version-Release number of selected component (if applicable):
2.4.0-0.20.beta.el6

How reproducible:
always

Steps to Reproduce:
0. instantiate a fresh RHEL6 Server
1. add pulp2.4 beta rhel6 repositories
2. add epel6 repositories
3. yum groupinstall pulp-server

Actual results:
No matching qpid available

Expected results:
pulp-server either requires a stock qpid version (0.14) or pulp2.4 repos provide required dependencies

Additional info:

+ This bug was cloned from Bugzilla Bug #1109253 +

History

#1 Updated by mhrivnak over 5 years ago

The rhel 6.5 release notes make it clear that qpid 0.14 is deprecated and no longer supported. The release notes explicitly recommend uninstalling it.

As such, relying on qpid 0.14 as part of rhel6 is no longer an option.

+ This comment was cloned from Bugzilla #1109253 comment 1 +

#2 Updated by bmbouter over 5 years ago

There is a Rally story US2838 that will include the necessary Qpid bits as part of the Pulp repo.

https://rally1.rallydev.com/#/7675694122d/detail/userstory/19720432613

+ This comment was cloned from Bugzilla #1109253 comment 2 +

#3 Updated by rbarlow over 5 years ago

Also, Pulp's RPMs should not require any particular broker as we also allow community users to choose rabbitmq-server. It is up to the user to install the broker packages of their choice.

+ This comment was cloned from Bugzilla #1109253 comment 3 +

#4 Updated by bmbouter over 5 years ago

I have added a note to the corresponding Rally story that indicates this bug should be updated when the story is merged/complete.

+ This comment was cloned from Bugzilla #1109253 comment 4 +

#5 Updated by bcourt over 5 years ago

All the qpid bits are now in the pulp rhel6 repo

+ This comment was cloned from Bugzilla #1109253 comment 5 +

#6 Updated by cduryee over 5 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1109253 comment 6 +

#7 Updated by pthomas@redhat.com over 5 years ago

verified

Installed pulp-server and all its dependencies were installed as well without any issues

+ This comment was cloned from Bugzilla #1109253 comment 7 +

#8 Updated by rbarlow over 5 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#10 Updated by bmbouter over 1 year ago

  • Severity set to 2. Medium

#11 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF